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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial data
files to be used to create maps inside a vector graphics program. MAPublisher allows you to perform all your
cartographic tasks where they should be done: in a powerful graphics environment.

MAPublisher 8.6 improves on the already powerful tools of previous versions by adding additional file support,
additional tools, and improvements to existing tools.

This tutorial guide assumes that the user is familiar with Adobe Illustrator CS4 or CS5, and has at least a basic
understanding of geographic information systems (GIS) terminology and concepts. The tutorials in this guide
should be used in conjunction with the MAPublisher 8.6 User Guide.

By following these tutorials, you will learn how to create maps using the MAPublisher features and tools in Adobe
lllustrator. This guide covers the steps necessary to build a map and perform fundamental cartographic and GIS
tasks. Together, MAPublisher and Adobe Illustrator will give you a totally integrated cartographic design software
system with graphics tools and geographic functions present in the same work environment.

TUTORIAL DATA
The tutorials in this guide use GIS data installed with MAPublisher. The tutorial data is installed at:

Windows XP
C:\Documents and Settings\All Users\Shared Documents\Avenza\MAPublisher 8\Tutorial Guide & Data\Tutorial Data

Windows Vista and Windows 7
C:\Users\Public\Public Documents\Avenza\MAPublisher 8\Tutorial Guide & Data\Tutorial Data

Mac0SX
/Applications/Avenza/MAPublisher 8/MAPublisher Tutorials/Tutorial Guide/Tutorial Data

Avenza produces and distributes helpful styles swatches, and symbols with the MAPublisher installation. These are
installed into Adobe lllustrator's default library installation locations and can be accessed through Adobe lllustrator
Symbols panel option menu: Open Symbol Library > MAP Symbols; the Adobe lllustrator Graphic Styles option menu:
Open Graphic Style Library > MAP Graphic Styles; and through the Adobe lllustrator Swatches panel option menu:
Open Swatches Library > MAP Swatches.

Helpful Styles and Symbols can be found in the following locations:

Windows XP
C:\Documents and Settings\All Users\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols

Windows Vista and Windows 7
C:\Users\Public\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols

Mac0SX
/Applications/Avenza/MAPublisher 8/Helpful Styles & Symbols
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1 Importing Map Data
See User Guide, Chapter 3.
1.1 Import a single map file

1. Create a new Adobe Illustrator document in landscape orientation.

2. Goto File > Import Map Data > Simple in the Adobe lllustrator menus to open the MAPublisher Simple Import
dialog box, or click the Simple Import button on the MAPublisher toolbar.

3. Select Mapinfo MIF/MID from the Format drop-down list.

4, Click Browse, navigate to the Tutorial Data folder and select world.mif.

¢
Simple Import

Format: [Maplnfo MIF/MID [*.mif] =) [ setngs.. | [ ok |

Dataset: YMAPublisher 8\Tutorial Guide & Data{Tutorial Datayworld.mif | Browse... Cancel

Encoding: [Uncode, 8-bit (UTF-8) ']

[
Source Coordinate System:
1iGS 84
[] Same as: -]

The Source Coordinate System is specified as WGS 84 since MAPublisher reads this information from the data
source. In cases where no coordinate system is specified, click the Specify button to choose a system.

5. With the dialog box matching the one above, click OK.

The data is imported and fit to the artboard. The layer world_area is added to Adobe Illustrator's Layers panel.

The MAP Views panel now contains a MAP View with the imported world layer. See chapter 4 in the MAPublisher

User Guide for more information on MAP Views.

6. Close the document without saving.

MAPublisher 8.6 Tutorial
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1.2 Import multiple map files simultaneously

Simple Import will import multiple map files simultaneously if the files are in the same data format, are in the
same coordinate system, and are located in the same directory.

1. Create a new Adobe Illustrator document in portrait orientation.

2. Go to File > Import Map Data > Simple in the Adobe lllustrator menus to open the MAPublisher Simple Import
dialog box, or click the Simple Import button on the MAPublisher toolbar.

3. Select MaplInfo MIF/MID from the Format drop-down list.

4, Click Browse, navigate to the Tutorial Data folder and select both fsatoronto.mif and torontostreets.mif (hold the
Command key (Mac) or the Ctrl key (Windows) to select multiple files). Click Open.

Simple Import
Format: [Maplnfc MIF/MID [*.mif] v] l Settings... ] [ OK ]
Dataset: her 8{Tutorial Guide & Data'Tutorial Data\torontostreets. mif
Encoding: [Unicode, 8-bit (UTF-8) -]

Lj
Source Coordinate System:
WGS 84
[[] same as: | @ waorld -

Although two files are selected for import, the Dataset box only lists the last file (alphabetical order).
5. With the dialog box matching the one above, click OK.

The layers fsatoronto_area and torontostreets_line are added to Adobe lllustrator's Layers panel. The MAP Views
panel now contains a MAP View called fsatoronto holding the two imported files.

L e N

6. Close the document without saving.
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1.3

HwnN =

Import map files to match an existing MAP Layer

Create a new Adobe lllustrator document in landscape orientation.

Click the Simple Import button on the MAPublisher toolbar.

Select Maplnfo MIF/MID from the Format drop-down list.

Click Browse, navigate to the Tutorial Data folder and select worldwest.mif. Click Open.

The selected file appears in the Dataset file list in the MAPublisher Simple Import dialog box. Notice that the
Source Coordinate System is Robinson.

Click OK to complete the import.

The layer worldwest_area is added to Adobe lllustrator's Layers Panel. The MAP Views panel contains the MAP
View worldwest projected in a Robinson projected coordinate system.

Repeat steps 2 to 4 above to import worldeast.shp, ensure the import Format drop-down list is Esri Shapefile.
In the Simple Import dialog box, the Source Coordinate System of worldeast.shp is indicated as Robinson.
Click OK to continue the import process.

In the Matching MAP View Found dialog box, accept the default Add to: worldwest option in the Destination MAP
View frame. Check Resize MAP View to fit.

Matching MAP View Found

Your data matches one or more MAP Views found in the
document, Please select a destination MAP View.

Destination MAP View:

© Addto: [ @ worldwest -]

Resize MAP View to fit

() Fit to page based on new MAP View

MAPublisher 8.6 Tutorial
1 Importing Map Data
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The worldeast layer is imported to match the worldwest layer. Notice that the scale of the worldwest_area layer has
been adjusted so that both layers can now fit inside the page extents. The layer worldeast_area is added to the
Adobe lllustrator Layers panel. In the MAP Views panel, the MAP View worldwest now contains both layers.

9. Close the document without saving.

1.4 Import map files with point per path limitations

Create a new Adobe lllustrator document in portrait orientation.

Click the Simple Import button on the MAPublisher toolbar.

Select Maplnfo MIF/MID from the Format drop-down list.

Click Browse, navigate to the Tutorial Data folder and select greenland.mif, click Open. Click OK.

HwnN =

MAPublisher

|® There were warnings and/or errors while reading the dataset(s),

A warning appears because the vertex count exceeds Adobe Illustrator's allowable 32,000 points per path.
5. Click Close to close the warning dialog box.

MAPublisher removes points in order to meet Adobe lllustrator's maximum points per path while maintaining
the integrity of the path's shape. Greenland looks distorted because there is no coordinate system defined.

6. Close the document without saving.

10 MAPublisher 8.6 Tutorial
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1.5 Import GIS file types that require optional settings

The Tutorial Data folder contains many GIS file formats. Various file formats require unique import settings that are
accessed by clicking the Settings button in the Simple and Advanced Importer dialog boxes. Refer to Chapter 3 of the
User Guide for the available settings for each format.

Create a new Adobe lllustrator document in portrait orientation.

Click the Simple Import button on the MAPublisher toolbar.

Select Esri Interchange File [*.e00] from the Format drop-down list.

Click Browse, navigate to the Tutorial Data folder and select capeverde.e00. Click Open.
Click the Settings button in the Simple Import dialog box.

Make sure Ignore TIClayer is unchecked. Click OK.

Click OK to complete the import.

Noun,rwn =

Note: As €00 files are generally an archive of several files, MAPublisher will reproduce an e00 import as distinct
Adobe lllustrator layers. Notice that MAPublisher generates point, area, line and text layers. An extra layer
appended with _tic_point is created to hold tic points, as was specified in the Settings dialog box.

8. Close the document without saving.
1.6 Import points

Along with importing Microsoft Excel files, MAPublisher can import delimited ASCII text files as point data provided
they contain coordinate values. Supported delimiters include: comma, return, end of line and tab in multiple formats.
Below is an example of ASClI that is supported for import:

“AZ,Antonio Tank,reservoir,Santa Cruz,4,23,312004N,1103943W,31.33444,-110.66194,,,,,,,Duquesne"
“AZ,Agua Prieta Substation,locale,Cochise,4,3,312006N,1093335W,31.335,-109.55972,,,,,,,Douglas"
“AZ,Adobe Spring,spring,Santa Cruz,4,23,312037N,1110234W,31.34361,-111.04278,,,,,,,Pajarito Peak"

Create a new Adobe Illustrator document in portrait orientation.

Click the Simple Import button on the MAPublisher toolbar.

Select Delimited XY Text Data [*.csv, *.tsv, *.txt] from the Format drop-down list.
Click Browse, navigate to the Tutorial Data folder, and select azdeci.txt.

HwWwN -

The Settings dialog box opens automatically. Specify the appropriate coordinate format of the data in the
Format drop-down list before selecting in which columns of the import file the coordinates will be found.

MAPublisher 8.6 Tutorial 1
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Use Decimals Degrees (D+[.d*]) as the Coordinate Format.

Use Column #10:-110.66194 for the Longitude coordinates and Column #9: 31.33444 for the Latitude coordinates.
Leave Use first line as a header unchecked because the first line of this file does not contain column headings.

Accept the default data types as assigned.

Examples:
7.5444W, 54.9777M | 79,44

or W'

Coordinate Columns:

Settings
Coordinate Format:
Format:  [Decmal degrees (D+L.d%) M
Decimal degrees, with optional direction indicator.

Notation: items in [ ] are optional, " means zero or more digits and
'+ means one or more digits. Direction can be indicated with ™, N,

Longitude: [Culumﬂ #10: -110.66194

=l

Latitude:  [Column 29: 3133444

=)

[] Use first line as a header (not detected)

Specify Schema:

a -
a
o
- L
s
o
@
r1s IPe—

Make sure that this dialog box matches the one above and click OK.

Since a delimited text file does not contain information regarding its coordinate system, it must be manually
specified. Check the dataset's metadata if you are unsure of the system. In this case we know that the Latitude

and Longitude are given in WGS 84.

Click the [No Coordinate System Specified] link. In the Specify Source Coordinate System dialog box, navigate to
Geodetic > World, choose the WGS 84 coordinate system and click OK.

Simple Impart

Farmat: |Deimited XY Text Data [*.csv *.tsv *txt]

v]l Settings... ][ oK

]

Dataset: MAPublisher 8\Tutorial Guide & DataVTutorial Data\azded. txt

Encoding: |Unicode, &-bit (UTF-8) -
L
Source Coordinate System:

Same as:

MAPublisher 8.6 Tutorial
1 Importing Map Data
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11. Save this document as MyPoints.ai in the Tutorial Data folder. It will be used again in exercise 8.3.

1.7

N —

oA W

S0V

Import multiple file types

Create a new Adobe lllustrator document in landscape orientation.
Go to File > Import Map Data > Advanced in the Adobe lllustrator menus to open the MAPublisher Advanced
Import dialog box, or click the Advanced Import button on the MAPublisher toolbar.

Click Add in the Advanced Import dialog box.
Select Mapinfo TAB [*.tab] from the Format drop-down list.
Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open. A coordinate system is detected.

Click OK to close the Add dialog box.

Advanced Import

ITI NAD27

| Coordinate System | Data Source | Features|

usatab 51

add... | [ Remove | [ Edit. |

Destination MAP View:
@) New based on:

Use existing:

() Create new:

Coordinate system: NADZ7

Page anchors: (0 px,612 px)

isual scale: 1:44326179.920453
Map anchors: (-178.2176, 18.9248)
Map unit: Degree

Map angle: 0

Auto-scale

Editor...

Cancel

The selected file appears in row 1 of the file list. Now add another file in a different map file format.

Click Add to open the Add dialog box.

Select Esri Shapefile from the Format drop-down list.
Click Browse, navigate to the Tutorial Data folder and select canada.shp. Click Open.

. Click OK to close the Add dialog box.

MAPublisher 8.6 Tutorial
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[ S——
Coortingte Syrtem  Data Somrre features =]
|afruscer [ 5 —

|2 NaDI? [ cansdashg i}

Destmation HAP View:
& tewbssedor  [[Hum =] ¢

Astmace

The selected file appears in the second row of the list.

11. In the Destination MAP View frame, usa is selected by default in the New based on drop-down list. This bases
the page scaling on the usa.tab file.
12. Check the Auto-scale option.

Destination MAP View:
@ New based on: |35]usa = | Coordinate System: NAD27
Page Anchors: (0,0)
LizEEnn | visual Scale: 1:68928620.2465%
Map Anchors: (-178.2176, 18.9248)
Auto scale Map Angle: 0
(@ Create new: Editor...

Auto-scale ensures all selected files are scaled to fit inside the page extents.

Note: Not checking the Auto-scale option will base the page scaling on the file selected in the New based on
drop-down list only. Therefore only this file is fitted to the current page extents, which may cause elements in
other selected files to be placed outside of the page boundary.

13. Click OK to import the two files.

Y

Notice that in the Adobe Illustrator Layers panel there are new layers called usa_area and canada_area. Also in
the MAP Views panel there is a new MAP View called usa containing the imported files.

14. Close the document without saving.

14 | MAPublisher 8.6 Tutorial
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1.8 Import MAP files with different coordinate systems

Create a new Adobe lllustrator document in landscape orientation.

Click the Advanced Import button on the MAPublisher toolbar.

In the Advanced Import dialog box, click Add.

Select Maplnfo TAB [*.tab] from the Format drop-down list.

Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open.

Click OK to close the Add dialog box.

o AW~

The selected file appears in row 1 of the file list. The coordinate system of usa.tab displays NAD27. The
coordinate system preview area lists various parameters of the file including the name of the coordinate system,
page and map anchors, visual scale, and map angle.

Click the Add button to add another file.

Select Esri Shapefile from the Format drop-down list.

Click Browse, navigate to the Tutorial Data folder, select worldwest.shp, and click Open.
0. Click OKto close the Add dialog box.

S 0N

Advanced Import

Cooedinate Syem  Data Sosrce  Features ="
1 NaDZT 5 usaitab il cancal
2 Roberson [ worldwestahp 57

Add... Remove Edt..

| Destination MAP View:
® Mewbasedon: | [l =

Creste new:

The worldwest.shp file appears in the second row of the file list and displays the Robinson coordinate system.

11. In the Destination MAP View frame, select the New based on option and choose worldwest from the drop-down list.

Destination MAP View:

@) New based on: wor\dwast | Coordinate system: Robinson

Page anchors: (0 px,612 px)

Use existing: Visual scale: 1:65884250.194927
Map anchars: (-15135197.5700, -5358152.1350)
[T Auto-scale Map unit: Meter
() Create new: Editor... Mep angle: 0

This bases the coordinate system and page scaling on the worldwest.shp file.

MAPublisher 8.6 Tutorial 15
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12. Click OK to import the two files into the Robinson coordinate system.

The map files are automatically sized to fit the page. Note that the Auto-scale option was not checked in
the Advanced Import dialog box. The page scaling was based on the worldwest.shp which contained larger
geographic extents than the usa.tab in all four compass directions.

In the Adobe Illustrator Layers panel, new layers called usa_area and worldwest_area are added. Also, in the
MAP Views panel there is a new MAP View containing the imported files (the MAP View has the same name as
the file selected for the MAP View destination).

- weoridurest
- usa area [
E

= /] [Non-MAP leyers]

[ A et 3
El

1MAP View o wd @8 W

13. Close the document without saving.
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1.9 Import map files to match an existing MAP View

This tutorial will produce the same results as Tutorial 1.8 - Importing MAP files in multiple coordinate systems.

Create a new Adobe lllustrator document in portrait orientation.

Click the Simple Import button on the MAPublisher toolbar.

Select Esri Shapefile from the Format drop-down list.

Click Browse, navigate to the Tutorial Data folder, select worldwest.shp, and click Open.
Click OK to close the Simple Import dialog box.

uhwN =

LAYERS MAFP VIEWS

1] CE N - - & i
® || reyerr [s] [ —— D
= /] [Mon-MAP layers]

/] tayers )

2lLayers i 1 MAP Viewr

& +ad Gl # v el el w §

In the Adobe lllustrator Layers panel there is a new layer called worldwest_area. Also in the MAP Views panel
there is a new MAP View called worldwest (which is set in the Robinson coordinate system).

6. Click the Advanced Import button on the MAPublisher toolbar, and then click Add.
Select Mapinfo TAB [*.tab] from the Format drop-down list.
8. Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open.

N

Advanced Import

| Coordinate System | Data Source | Features| ok
H NuD27 usatab st

Add.. | [ Remove |[ Edt. |

Destination MAP View:

P ——
Page anchors: (0 px,612 px)
Visual scale: 1:44326179,920453

© New based on:

Use existing -
Map anchors: (-178.2176, 18.9248)
Map unit: Degree

Map angle: 0

Auto-scale

© Create new: Editor

9. Inthe Destination MAP View frame, click the Use existing option and choose worldwest from the drop-down list.

Destination MAP View:
(@) New based on: [ usa ~ | Coordinate system: Rabinson
) Page anchors: (0 px,612 px)
@ Use existing: @ worldwest | visual scale: 1:65884250,194927

[[] Auto-scale

() Create new: Editor...

Map anchors: (-16195197.5700, -5888152.1350)
Map unit: Meter
Map angle: 0

View the coordinate system of this map file in the coordinate system preview area.

MAPublisher 8.6 Tutorial
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10. Click OK to import the file based on the Robinson parameters of the worldwest_area layer.

The file is imported and reprojected to automatically align with the worldwest layer. This functionality allows
you to easily register multiple files with different coordinate systems.

In the Adobe lllustrator Layers panel there are new layers called usa_area and worldwest_area. Also in the
MAP Views panel there is a new MAP View called worldwest containing the imported files set in the Robinson

coordinate system

11. Close the document without saving.

1.10 Assign a source coordinate system prior to import

1. Create a new Adobe Illustrator document in portrait orientation.
2. Click the Advanced Import button on the MAPublisher toolbar. In the Advanced Import dialog box, click Add.
3. Select Esri ArcInfo Generate from the Format drop-down list.
4, Click Browse, navigate to the Tutorial Data folder, select ukrail.gen, and click Open.
5. Click OK to close the Add dialog box.

Adverced Impont

[ ontnat st Outa S estures| =3

|3 trinown B voadgen 4273 poe

A B 30
T‘::l::\'m ks

The selected file appears in the first row of the file list and it has an unknown coordinate system.

18 MAPublisher 8.6 Tutorial
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6. Inthe Advanced Import dialog box, with the first row selected, click Edit.

7. In the Edit dialog box, click the [No Coordinate System Specified] link, go to Projected > Europe > United Kingdom,
choose British National Grid, and click OK.

8. Click OK to return to the Advanced Import dialog box.

cvared lmport

| [Coordinate Sstem  DataSovrce | Features| | =)

t; et Hitiomal G| [ vkrailgen] 4273

[Lao. ][ memore |[ tdv. |

Destination MAP View:
@ tewbsssdon: | [ ural = | Comdnatr aystem: Britsh Maberas Gril
Page anchors: [0 512 )
sty = | Vieus scale: 13 4334096, 75003
Mo archors: (80380, 3419, 31406.6337)
utoscale Mg it Meler
¢ e ap angle: 0

Under Destination MAP View frame, view the coordinate system information in the area to the right.

9. Click OK to import the file in the British National Grid coordinate system.

10. Close the document without saving.
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1.11 Transform a coordinate system on import

Read about the MAP View Editor in chapter 4 of the User Guide before completing the following tutorial.

Create a new Adobe lllustrator document in portrait orientation.

Click the Advanced Import button on the MAPublisher toolbar, and then click Add.
Select Esri Shapefile from the Format drop-down list.

Click Browse, navigate to the Tutorial Data folder, select ukpoly.shp,and click Open.
Click OK to return to the Advanced Import dialog box.

uhwN =

Advanced Import

| Coordinate System | Data Source | Features| oK
’T‘WGSEA ukpoly.shp 6
add.. | [ Remove | [ Editn. |

Destination MAP View:

@ Mewbasedon: | []ukpoly v | Coordinate system: WGS 84
Page anchors: (0 px,612 px)
Use existing: Visual scale: 1:5640124.905207

Map anchors: (~10,4780, 49.9096)
Map unit: Degree
Map angle: 0

Auto-scale

) Create new: Ediitor.

The selected file appears in Row 1 of the file list. The coordinate system of ukpoly.shp is currently WGS 84.

6. Inthe Destination MAP View frame, select the Create New option, and click the Editor button to open the Map
View Editor dialog box.

@) Please configure your new MAP View before continuing.

[ Add... ][ Remove H Edit...

Destination MAP View:
(©) New based on: (28] wkpoly Click the Editor button to customize the new
Destination MAP View.
Use existing:

Auto-scale
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7. Inthe MAP View Editor, click the coordinate system link WGS84. Click the *Recent* category list under Coordinate
Systems > Projected and choose British National Grid. Alternatively, go to Projected > Europe > United Kingdom to choose

the British National Grid coordinate system.

] Specify Source Coordinate System =)
Datasource: C:\Program Files (x86)\Avenza\MAPublisher 8\Data Source Files\geodata,ml
Custom Data:  C:\ProgramData)y ' WMAPUblisher el [—]

Close
Folder © [ Display Name - Name
4 Coordinate Systems £\ BIH TERRESTRIAL SYSTEM Coordinate System BIH TERREST
Al [\ British National Grid British Natio Save
“Recent” £ Goode Homolosine Goode Hom
 “Seach Hitory 8 nase it
» Geodetic £ NADS3(CSRS) MADB3(CSRS
> Projected £ Polyconic, meter Polyconic, m
&4 Stereographic (North Polar Aspect), meter Stereographi
& wesss WS
&4 Winkel-Tripel, Central Meridian Greenwich  Winkel-Tripe
< i J v
+ | @ +| @ |
Search i
Folder: <select an object folder to activate ssarch functionality >
Find: in |Name al |

8. Click OK to close the Specify Source Coordinate System dialog box.
9. Click OK to close the MAP View Editor and return to the Advanced Import dialog box.

Destination MAP View:
© Newbasedon: | [1] ukpoly
Use existing:

Auto-scale

Coordinate system: British Mational Grid
Page anchors: (0 px,612 px)

Visual scale: 1:5599877.522118

Map anchors: (-179492, 5052, 9898.2250)
Map unit: Meter

Map angle: 0

Under Destination MAP View, view the coordinate system information in the area to the right.

10. Click OK to import the file in the British National Grid coordinate system.

11. Close the document without saving.
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2 MAP Views and Georeferencing
See User Guide, Chapter 4
2.1 Create MAP View on import

1. Open usa48.ai from the Tutorial Data folder.

2. Inthe Adobe lllustrator menu, click Window > MAPublisher > MAP Views to open the MAP Views panel or click
the MAP Views button on the MAPublisher toolbar.

3. Use Simple Import to import usa.tab from the Tutorial Data folder.

MAP VIEWS

ONIEE=—  DE) [T
& || []ussare= o [A] usarea )
= [ @ w1
P\ usa_area1 O]

/] [Nen-MaP layers]

2 Layers owal Gl 3 | 2MaPViews P i o8 w 3

Notice that a MAP View called usa 1 is automatically created. The 7 denotes that a MAP View already exists with
that name, so it adds a suffix to differentiate it. Each Adobe Illustrator layer comprising the MAP View is depicted
with an icon that represents the Feature type contained on each of the map layers.

4. Continue with the next tutorial.

2.2 Import a MAP View from existing MAPublisher documents

Continue working with the previous tutorial.
1. Keep the usa48.ai document open, create a new Adobe lllustrator document and make it active.
2. Click the top right corner of the MAP Views panel to open the options menu and click Import MAP Objects.

O s b v
- Nen-MAP -
£ on-ap ayerd New MAP View For Photoshop Paths...
Layer 1

Duplicate Selection
Edit Selection...
Delete 'Layer1'

0 MAR Views wo e el W T = Add MAP Layer...

Specify Anchors...

Export Caardinate System to File...
Export Layer...

Layer Name Search & Replace...
Sort Art on Layer...

Edit Layer Note...

Load Custem Coordinate Systems...
Edit Custom Coordinate Systems...

Import MAP Objects...

Preferences...

A list of MAP Views are available from any opened document containing MAP Views. In this case, the MAP Views
usa and usa 1 are available to import.
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Import MAP Objects

Copy MAP layers belonging to imported MAP Views

Chedk the MAP ohjects you wish to import:
= " | Ce=]
Cancel
% [ conee |
4 @ MAP Views [}
@ usa V]
@ usal

Check the usa check box in the Import column and click OK.

The MAP View is imported into the new document along with all the MAP Layers within that MAP View. It

maintains the original scale and position of the usa MAP view.

Close the active document without saving, but keep the usa48.ai document open.

Continue with the next tutorial.

2.3 Duplicate and delete MAP Views

Continue working with the previous tutorial.

In the MAP Views panel, select the usa MAP View. Then click the panel option menu and click Duplicate "usa".

Copy of usa
-

[A] usa_area 3
7 [@ us1
uss_area 1 (]
|| [Non-MAP lzyers] i
3 MAP Viewrs @ il -8 o 3

A new MAP View called Copy of usa is created. It only duplicates the MAP View and not the MAP Layers that are

contained in the source.

2. Select the usa MAP View and click the Delete button.

MAPublisher

MAP View is not empty.
The selected MAP View contains one or more layers that will also be deleted.

% Delete MAP View and child layers.

those layers contain sub-layers, they wil also be deleted.

Delete the selected MAP View and any layers it contzins. If any of

A message dialog box states that the MAP View is not empty. Click Delete MAP View and child layers.

3. Close the document without saving.
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2.4 Transform coordinate systems by drag and drop

1. Create a new Adobe Illustrator document in landscape orientation.
2. Use Simple Import to import world.mif from the Tutorial Data folder.
3. Use Simple Import to import worldwest.shp from the Tutorial Data folder.

There are two MAP Views: one called world, in the WGS 84 coordinate system, that contains the world_area layer;
and the second called worldwest, in the Robinson coordinate system, that contains the worldwest_area layer.

4. Inthe MAP Views panel click the worldwest_area layer and drag it to the world MAP View.

MAP VIEWS
- wiorld - - world
[ werdares o T [ vordares o
* 0 ot | > | -
r A m =
= | /] INen-MaP layers] = | /] INon-MAP layers]
[ A tayers & _ [ 1A ayens [P
2 MAP Views P i o8 » 3 : 2 MAP Views o w28 » 3

The worldwest_area layer is transformed into the WGS 84 coordinate system and matches the page scaling of
the world_area layer.

5. Drag worldwest_area back to the worldwest MAP View and it will transform the layer back to the Robinson
coordinate system.
6. Keep the document open for the next tutorial.

2.5 Drag layers into existing coordinate systems

Continue working with the previous tutorial.
1. Use the Toggle Visibility button in the Adobe Illustrator Layers panel to hide the world_area layer.
2. Inthe Adobe lllustrator Layers panel, create a new layer called Extras, and move it to the top of the layers hierarchy.
3. With the Extras layer selected, roughly trace over some features that exist on the worldwest_area layer using the
Adobe lllustrator Pen tool and give it a red colored fill.
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The new features are polygons. Make sure that the elements are closed so that the start and end points of the
lines are coincident.

4. Inthe MAP Views panel, click the Extras layer and drag it into the worldwest MAP View.
5. Inthe Undefined Layer dialog box, select Area from the Feature type drop-down list, and click OK.

Undefined Layer - Extras

Advanced:

[E] Base attribute schema on: | [A] worldwest_area ~ | [ Apply toall

Chedk this option 1o inberit atwibute information from another layer.

The Extras layer is now stored in the same coordinate system as the worldwest MAP View.

6. Keep the document open for the next tutorial.

2.6 Drag new layers into different coordinate systems

Continue working with the previous tutorial.

1. Inthe Adobe Illustrator layers panel, use the Toggle Visibility buttons to hide the worldwest_area layer, and to
make the world_area layer visible. The Extras layer is already visible.

2. Inthe MAP Views panel click the Extras layer and drag it into the world MAP View.

The Extras layer is moved to the coordinate system of the world MAP View. It is immediately transformed from
Robinson to WGS 84 coordinate system and aligns with the data in the world_area layer.

3. Keep the document open for the next tutorial.
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2.7 Editlayer names using search and replace

Continue working with the previous tutorial.
1. In the MAP Views panel option menu, click Layer Name Search & Replace.

= @ word -
[ [A eeres
[~ Al vorid_area

- wiorldveest

r
[}
r Delee ‘worldwest_ares
@ -
gl

Mew MAP View For Photoshop Paths...
Duplicate Selection

Edit Selection...

= /] Non-MAP layers]
[~ /] tayert
2 MAP Views P il @B, w0

Add MAP Layer...

Specify Anchors...

Export Coordinate System to File...

Export "worldwest_area"...
Layer Name Search & Replace...
Sort Art on "worldwest_area”...

Edit Layer Note...

Load Custom Coordinate Systems...
Edit Custom Coordinate Systems...

Import MAP Objects...

Preferences...

2. Inthe Find what box, type _area. In the Replace with box, type _layer. Click the Replace All button.

Layer Name Search & Replace

Find what: -jrea 4 Replace i
Replace with: _layer

The text _area is replaced with _layer in the name of all applicable layers.

MAP VIEWS MAP VIEWS

~ @ wod < @ e

[ [A] e la I [A] ear= la

[~ [A] worid_area 5] - wiorld_layer (5]
= [ worldwest P |~ @ workwes

m i
= [/] [Non-MAP layers] = /] [Non-MaP layers]

[ A tayert B - [ A tayers & -
2 MAP Views v wd ol w 3§ 2 MAP Views v wid o8 w 3

3. Close the document without saving.
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2.8 Specify a source coordinate system after import

Create a new Adobe Illustrator document in portrait orientation

Use Simple Import to import ukrail.gen from the Tutorial Data folder (do not specify a coordinate system).

In the MAP Views panel, double-click the ukrail MAP View to open the MAP View editor. Close the warning dialog
box that appears (it appears because no coordinate system was specified).

In the MAP View editor dialog box, click the [No Coordinate System Specified] link to open the Specify Source
Coordinate system dialog box.

Go to Projected > Europe > United Kingdom and choose British National Grid.

]G]
H.:
g
7

e Page Mgrmert
Soale: 4 134GEA5, LGS _ i kol |v]  ULX0.500000 oo ggg
snge: 0 3 degrees (@) [ LY. 75250000 = gop
Source Conrdinate Systeme

riagh Nt Gl 8 (@) [romme]

Perfarm Coordmate System Tramformataon:

Coordnate Spsien Soecfied) W o

Click OK to close the MAP View editor dialog box.

The source coordinate system for the file is now British National Grid. The MAP View is assigned a coordinate
system and can now be transformed.

Close the document without saving.

29 Transform a coordinate system using the MAP View editor

Create a new Adobe lllustrator document in portrait orientation.
Import fsatoronto.mif from the Tutorial Data folder.

The map file is in the WGS 84 coordinate system.

In the MAP Views panel, double-click the fsatoronto MAP View to open the MAP View editor.
Change the name of the MAP View to Postal Code Zones.

MAPublisher 8.6 Tutorial | 27
2 MAP Views and Georeferencing



5. Check the Perform Coordinate System Transformation check box to enable its frame options and click the [No
Coordinate System Specified] link.

6. In the Specify Destination Coordinate System dialog box, go to Projected > UTM > NAD83, choose NAD83 / UTM zone 17N,
and click OK.

Hame:  fratoronto Page Algriment

1t T - WK 2000000 fle OOD
Sealer 1t 23705634000 s Autn seuie : ot
woge: 000 3 degrees (@) () W Tz 2w won
Source Coondnate Systest
Wiz 84 e
9] Perfom Coordinats System Transiormation:

R i AN [ remre, |

Datm sl MDY 1o WS A (IS Vi Wrklocpraad)

The Preview Pane displays how the new coordinate system is fit to the page. UTM zone 17N is a proper
projected coordinate system to use for this area.

7. Click OKto close the MAP View editor dialog box.

The MAP View is transformed from WGS 84 to NAD83 / UTM zone 17N. See Appendix A2 on Projections and
Datums in the User Guide for more information.

8. Keep the document open for the next tutorial.

28 | MAPublisher 8.6 Tutorial
2 MAP Views and Georeferencing



2.10 Edit scale and position

1. In the MAP Views panel, double-click the Postal Code Zones MAP View to open the MAP View editor.

2. Change the map scale to 1: 35,000 by typing 35000 in the Scale box.

3. Inthe Page Alignment frame, there are nine squares in the alignment control graphic. Click the center square to
reposition the data to the center of the page.

Fefit "Pertal Codle Tomey”

Seser 1= 35000.000000 3 A | WK 146 H« 000

Joge: Qo0 5 Lﬂlthl LY 547208 e ooo
Sowrce Coordinate Systes:
\ e
[ Perform Coordinate System Transtommation:
Desteoor: HADD /UM gone 17 g

Same -

Cntum e AL b 4. AL LS, < e ikl

The Preview Pane shows the new data extents and the page anchor values have been automatically updated.

4. Click OK.

The Postal Code Zones MAP View is rescaled and repositioned in the center of the page.

5. Inthe MAP Views panel, double-click the Postal Code Zones MAP View to open it again.
6. Inthe Angle box, type 343.00 to specify an angle of rotation, then click OK.
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7.

The layer is now rotated. Georeferencing has not been affected.

Close the document without saving.

2.11 Copy a coordinate system from one layer to another

u

30

Create a new Adobe lllustrator document in landscape orientation.
Import worldwest.mif from the Tutorial Data folder.

The map file is in the Robinson coordinate system.

Select the Canada polygon shape and assign a fill color to it.

In the MAP Views panel, double-click the worldwest MAP View to open the MAP View Editor.

Change the map scale to 1: 250 million by typing 250000000 in the Scale box.

Click the Show Anchors check box to display the map and page anchors (if the artboard is blocking the anchor
numbers, click the zoom out button a few times). In the Page Alignment frame, click the top left square to
reposition the data to the top left of the page.
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=0 -]

Name: wovevest b i

Seses 1@ 250000000.000000 |31 [ Aumacse v W ¥ 0500067 . :88
T @ & LY SL5EET e apo
Source Coonfinate Systes:

Sabmn 6 (&) [Fomre. ]

The Preview Pane shows the new data extents and the Page Anchor values have been automatically updated.
Move the artboard in the preview if the anchor values block the extent box.

7. Click OK.

The worldwest MAP View is rescaled and repositioned in the upper left corner of the page. This can be used as a
small inset map used referencing Canada to the Western Hemisphere countries.

8. Import canada.shp from the Tutorial Data folder.
The map file is in the NAD27 coordinate system.
9. Inthe MAP Views panel, double-click the canada MAP View to open the MAP View Editor.
10. Check the Perform Coordinate System Transformation check box to enable its frame options. Check the Same

As check box and select the worldwest MAP View in the drop-down list. Notice how the destination is set to
Robinson and the datum shift is NAD27 to WGS84(88).
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11. In the Page Alignment frame, click the center square to reposition the data to the center of the page.

Edit “canada”
[V -
@ o]
=
| g
=
)

e e —— P 1
=l Frevews: [Coowedboxes =] []
Mame: canada Page Algrment
Sesle: 1 JEBIMISNS [T Jefoscale |+ W 0.0000%0 B EES
Angle: 000 5 degrees &Lh_ Wr SIS = aoo
Naoz7 @@ [reom
| Pertorm Coonfinate System Translormation:

Destiration: Ackinson W | Frorie
7 samcos: | ) woridwest -

Dt shift: HADZT bo WIS 4453)

The Preview Pane shows the new data extents and the Page Alignment values are automatically edited.
12. Click OK.

The MAP View is transformed to match the coordinate system of the worldwest MAP View.

13. Close the document without saving.

32 | MAPublisher 8.6 Tutorial
2 MAP Views and Georeferencing



2.12 Create a new MAP View

This tutorial provides a basic overview of assigning georeferencing information to existing Adobe Illustrator
documents. Please see Georeferencing an Adobe lllustrator File in the MAPublisher 8.6 User Guide.

1.

oA wWN

In Adobe lllustrator, open toronto.ai from the Tutorial Data folder.

This is a regular Adobe lllustrator document digitized in WGS 84 (degrees). It contains two Adobe lllustrator
layers that do not have any georeferencing or attribute information. They are located in the [Non-MAP layers]

section of the MAP Views panel.

In the MAP Views panel option menu, choose New MAP View. Close the warning dialog box.

Rename the MAP View to Toronto.

Under the Source Coordinate System section, click the [No Specified Coordinate System] link.
In the Specify Source Coordinate System dialog box, go to Geodetic > World, choose WGS 84, and click OK.
Type 26175.038531 in the Scale box. The data is in degrees so the scale value is approximated using the common

formula 1°= 111.353 kilometers.

Hew MAP View

Perfarm Coordimate System Transformatios:

Mo Comrsheunte Systrn S| P | FromFe

™o freviens: [Cooredbores | [F]
Hame: Toronitn: Fage Algment

i 3 BmOBEN 5] e - WX 0000000 $e DOO
Seale: 1= ME17S.038531 .‘ ity e ooo
doe: 0.00 [3] degrees (@] Iy i Ly
Source Coardinate Systen:
1 & [rempe.. |

i

7. Make sure that the dialog box matches the one above and click OK.
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8. Make sure the Toronto MAP View is selected and choose Specify Anchors in the MAP Views panel option menu.

T m———e—
= /] [Nen-MAP layers]

/] Postcode Zones A
/| . Al Edit "Toronta"...

New MAP View For Photoshop Paths...

Duplicate "Toronto"

Delete ‘Toronto'

Add MAP Layer...

1 MAP View P el w 3 Specify Anchors...

Export Coordinate System to File...

Export “Taronto”...
Layer Name Search & Replace...
Sort Art on Layer...

Edit Layer Note...

Load Custom Coordinate Systems...
Edit Custom Coordinate Systems...

Import MAP Objects...

Preferences...

The Specify Anchors dialog box establishes the tie-in point between map anchors (real world coordinates) and
page anchors (coordinates in page units). In this case, we'll use a MAP Location point to set the map anchor.

9. For the Map Anchor, click the blue MAP Location button and chooses Toronto Map Anchor. It has a long/lat
value of -79.411893, 43.611883 degrees. Leave the Page Anchors as its default 0.000000, 0.000000 pt.

Specify Anchors

Input Coardamate System: Coo [
Cancel

B Line MAP Ymn's co it sysiem
Page Anchar:
o K 0.000000

R R
=

o T 0000000

Make sre you have set rulers o Giobal Rulers when
i e piage kacation with sy Tt atce ook,

Yous 6 feed e cption ot View > Ruers. » Change 1o Gl Ruders
Map Anchor:

o Leng: -T411883 s (gl
o Latr 43601883 deg

*  Torenta Map Ancher

Artbosrd 1 "

MAP Locations...

MAP Locations are used to create reference points in the artboard which can be used in other MAPublisher
tools such as Area Plotter, Line Plotter and MAP Point Plotter. These anchor points are using WGS 84 coordinate
system so the Use MAP View's coordinate system option is selected. If needed, there is an option to specify
anchors using a coordinate system different than the MAP View.

Note: The map/page anchor relationship can be established at any known tie-in point (preferably within the
extents of the dataset being georeferenced).

10. Make sure that the dialog box matches the one above and click OK to apply the changes.
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11. In the MAP Views panel, click and drag the Postal Code Zones layer into the Toronto MAP View.

In the Undefined Layer dialog box, choose Area in the Feature type drop-down list and click OK.

Undefined Layer - Postcode Zones

Feature type: [ A& area

z) |

oK

J

Cancel
Advanced:

|| Base attribute schema on:

Apply to all

Check this option 10 inherit the atiribute strucure from the spec e

fied lzyen

The Postcode Zones area layer is moved to the specified coordinate system of the Toronto MAP View.

12. Click and drag the Roads layer into the Toronto MAP View.

13. In the Undefined Layer dialog box, choose Line in the Feature type drop-down list and click OK.

Undefined Layer - Roads

Feature type: [[]Lme -][ oK J

Advanced:

|| Base attribute schema on:

Check this option 1o inherit the

attribute suchre

The Roads line layer is moved to the specified coordinate system of the Toronto MAP View.

= [@ Torento
Roads
Pasicode Zones
] [Non-MAP lzyers]

1 MAP View o il B e F

Both Adobe lllustrator layers are now map layers, in the specified coordinate system of the Toronto MAP View.

14. Close the document without saving.
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2.13 Export data to GIS formats

1. Create a new Adobe Illustrator document in portrait orientation.

2. Use Simple Import to import fsatoronto.mif and torontostreets.mif. Click OK to add the fsatoronto MAP View.

3. Inthe MAP Views panel, select the fsatoronto_area layer and in the MAP Views panel option menu, click Export
“fsatoronto_area"

4. Inthe Export dialog box, choose Esri Shapefile from the Format drop-down list, click Browse, navigate to a
location to save the shapefile, and click OK. The Dataset box is populated with the directory path.

Export "fsatoronto”

Format: Esrr shapefie [~.shp] <) [ setings.. | [ ok |
Dataset: APublisher 3/Tutorial Guide & Data/Tutorial Data
Character encoding: [System |

5. Click OK to export the file.

View the contents of the destination folder. The fsatoronto layer is exported as an Esri Shapefile with all
attributes and georeferencing intact. This Esri Shapefile consists of four files: fsatoronto.shp, fsatoronto.shx,
fsatoronto.dbf, and fsatoronto.prj. It is ready to be used in software supporting this format. Descriptions of these
file extensions can be found in chapter 2 of the MAPublisher 8.6 User Guide.

-~

Name Date modified Size

ﬁfsatomnto.dbf 09/11/2011 3:44 PM 2KB
| fsatoronto.prj 09/11/2011 3:44 PM 1KB
|| fsatoronto.shp 09/11/2011 3:44 PM 6 KB
| fsatoronto.shx 09/11/2011 3:44 PM 1KB

6. Inthe Adobe lllustrator Layers panel, select all objects on the torontostreets_line layer.
7. Click the MAP Attributes panel button on the MAPublisher toolbar. Resize the MAP Attributes panel to see all
the attribute column headings and click the Edit Schema button.

x
MAP ATTRIBUTES =

Layer: [ L] torontostreets_line (1197 lines selected) = ]
[S] Street [ FromLeft M TolLeft [MFromRight [T ToRight M Type =

1 ACELA 0 0 0 0 o 4

2 ADELAIDE PL 0 0 1 11 1]

3 ADELAIDESTE 0 0 0 0 1]

4 ADELAIDESTE 6 14 1 25 1]

5 ADELAIDESTE 36 48 33 53 0 -

K4 00f1297) b | 1

1197 lines selected @@@
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8. Inthe column list, click #Length and check the Visible check box. Click FromLeft to view its schema and uncheck the
Visible check box and click OK.

Edit Schema

[] [ B #1ayertame
E] I 21d

ZMame
[ #VertexCount
5] #style
[R] #StrokeWeight
[B] #PathClosed
[R #Length
FArtScale
Street
I Fromleft
I Toleft
[ FromRight
@] ToRight
M Tvoe

e

Name:
Display Name:

Type:

Default Value:

[[] visible
[] Read-only

FromLeft

FromLeft

[7] Derive value from expression:

Expression:

oK

The #Length attribute is visible now and the FromLeft attribute is hidden.

MAP ATTRIBUTES
Layer: l [L torontostrests_line (1197 lines selected) v]
[Rl#Length Street [T Toleft MFromRight [T ToRight MType -
1 000650 deg ACE LA 0 0 0 0 [
2 0.000608 deg ADELAIDE PL 0 1 11 0
3 0,000724 deg ADELAIDESTE 0 0 0 0
4 0.001238 deg ADELAIDESTE 14 1 25 0
5 0.0 7 deg ADELAIDESTE 48 33 53 0 -
M4 uofug?‘./ 7]

1197 lines selected

<) (@EEME

LN x

Before continuing, the other Integer type columns need to be hidden.

9. Right-click the ToLeft column and click Hide Column.

Note:

LN x

MAP ATTRIBUTES

Layer: | L} torontostreets line (1197 Ines selected)

=)

[Rl#Length Street
0000650 deg ACE LA

508 cleg ADELAIDE PL

deq ADELAIDE ST E

0001238 deg ADELAIDE ST E

0.000777 dey ADELAIDE STE

[T ToLeft

P P

1197 lines selected

© & 61

Resize all to fit content

Resize ‘ToLeft' to fit content

Hide Column

New Column...

Edit ‘TolLeft'...

Delete ‘ToLeft'
Show/Hide Columns

M Type

e ]

0
0
0
0
0

00f 1197| ) | Wl
(&) (=)= E
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10. Hide the remaining columns: FromRight, ToRight and Type.

LN x

MAP ATTRIBUTES

Layer: [ |Ll torontostreets_line (1197 lines selected) - ]

[Rl#Length [S]Street
0.000650 deg ACE LA

deg ADELAIDE PL

deq ADELAIDE ST E

deg ADELAIDE ST E

deg ADELAIDE ST E o

M4 00f1297) b |

1197 lines selected g @@E} i

%)

] »

[CRF ST

11. Ensure torontostreets_line is selected. In the MAP Views panel option menu, click Export “torontostreets_line"
12. In the Export dialog box, select Maplnfo TAB [*.tab] from the Format drop-down list, click Settings, ensure the
option for Export visible attributes only is checked, and click OK.

Settings

[] Keep format extension
Export visible attributes only

This ensures that only visible attributes are exported (#Length and Street columns in the attribute table).

13. Click Browse and navigate to a location to save the export and click OK.

Export “torontostreets_ling”

Format: [Mapinfo TAB [*.tab] o) [ settings... | [ ok |
Dataset: 1er 8/Tutorial Guide & Data/Tutorial Data/Export
Character encoding: System -

14. Click OK to export the layer.

The torontostreets_line layer is exported to Maplnfo TAB format with the specified attributes and georeferencing
intact. It is ready to be used in software supporting this format. View the contents of the destination folder.
You'll see that four new files were created: torontostreets.tab, torontostreets.dat, torontostreets.id, and
torontostreets.map. Descriptions of these file extensions can be found in chapter 2 of the User Guide. Each file
format has its own settings.

15. Close the document without saving.

38 | MAPublisher 8.6 Tutorial
2 MAP Views and Georeferencing



2.14 View coordinates and create a MAP Location

1. Open usa48.ai from the Tutorial Data folder.
2. In the MAPublisher Toolbar, click the MAP Info button.

The MAP Info panel appears.

3. Move the mouse cursor (it looks like a cross hair) to a location on the map to view its geographic coordinates.

MAF INFO

WX: 603,340.547040 WY: 1,913,160.256024
Geodetic - Longtuds: -B8.860509 Latitude: 40.032050
Scale 1: 20,000,000.000000 Angle: 0.00%
Map X: -2,354,590.00000 Page X: 63.208984 pt
Map Y: 311,602.00000 Page Y: -107.033203 pt

Coardinste System: United States: Albers Equal Area, mater
Units: Meter

The MAP Info panel shows the WX and WY values and are constantly updated as the mouse cursor is moved
around the map document.

4. Inthe Adobe lllustrator Tools, click the MAP Locations tool.
5. Click anywhere on the map to create a MAP Location.

Add MAP World Location

Name: =

Coordinate System: (@ United States: albers Equal Area, meter
() Geodetic base: NAD27
Copy to Cliphoard

Input format: Projected units

o X: -190,408,945304 m

o Vi 1,765,012.177957 m

A MAP Location is ready to be created. It is created in projected units of meters. Optionally, click the Copy to
Clipboard button to make the coordinate values available beyond this dialog box.

6. Click OK.

A blue MAP Location pin is placed on the artboard. When the MAP Location tool is enabled, hovering near the
pin will make its label visible. To see a list of all MAP Locations, open the MAP Locations dialog box from the
MAPublisher toolbar.

7. Close the document without saving.
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3 MAP Attributes

See User Guide, Chapter 5
View, edit and zoom with MAP Attributes

Create a new Adobe lllustrator document.

Import world.mif from the Tutorial Data folder.

With all of the art selected on the world_area layer, open the MAP Attributes panel (choose Window >
MAPublisher > MAP Attributes) or click the MAP Attributes button on the MAPublisher toolbar.

To edit attribute values, double-click inside a cell and type a new value.

All attribute values and some property attributes can be edited. MAPublisher creates some attributes which
have the hash symbol (#) as a prefix. These attributes are editable (but must be made visible first). However,
#Area, #Perimeter, #VertexCount, and #Length are properties of the geometry and cannot be edited.

Keep in mind to enter values that correspond with a column's type (e.g. only enter numbers into a column of
type Real or Integer). The edits are automatically maintained in the attribute table once entered.

The widths of the columns in the MAP Attributes panel may be changed by clicking on the column separator
and dragging it left or right. Right-click and click Resize all to fit content.

Click the column heading to sort column in an ascending manner. Click the column heading again to sortitina
descending manner.

I

10l =

MAP ATTRIBUTES
Layer: | [ warld_area (220 areas selected) -
[SlCountry  [S]Capital [RlArable Pt [R]Population [RIPop_Grw Rt  [RlLiteracy [RlInflat Rate nd
1 Afghanistan  Kabul 120 16,450,304.000000000 52 290 920
2 Albania Tirane 210 3,335,044.000000000 18 720 00
3 Algeria Algiers 30 26,022,188.000000000 15 500 200
4 Andoma  Andorra la Vella 20 53,197.000000000 24 00 00
5  Angola Luanda 20 8668,281.000000000 27 420 B2
6  Anguilz  TheValley (1] 6,922.000000000 05 950 45
7 Anterctica  none 00 0.000000000 00 00 00
5 Antigus st Johns 180 63,917.000000000 04 890 35
9 Argentinz  Buenos Aires 90 32,663,983.000000000 11 950 13450
10 Armenia  Verevan 00 3412,000.000000000 00 00 0 .
o i ] v
W]4] tof220 [ [l
220 areas selected Ee) (=) () Be) B

Zoom to a specific piece of art via the MAP Attributes panel. Select an attribute record and click on the Zoom to
Feature icon [ xJ. MAPublisher zooms to the area of the file where the artwork is located and displays it within
visible handles.

A Laves | I e (3 e scecoe) - =
SiCoumtry 5 Copasl Rswbie P B Papuistion RiwpGrmfn  Rlsewy =
) Mmoo oo Gty B40 B0, 104 000000000 a2 L)

7. Keep the document open for the next tutorial.

MAPublisher 8.6 Tutorial
3 MAP Attributes



3.2 Add anew column to a MAP Attribute table

Continue working with the previous tutorial.
1. If necessary, open the MAP Attributes panel and select all objects on the world_area layer. The panel displays all
of its attribute columns and values.

2. Click the Edit Schema button at the bottom of the MAP Attributes panel. @

The Edit Schema dialog box displays the columns associated with the MAP Attributes table on the currently
selected layer.

3. Click Add to add a new attribute column.
4. Inthe Name box, rename Attribute1 to Head of State.

Note: Notice that spaces are not accepted for column names. MAPublisher inserts an underscore (_) if a space is
typed into a column name. Also, notice that the Display Name box is populated with the same name. This can
be changed to reflect a name with no spaces in it.

5. In the Display Name box, remove the spaces, so the name becomes Head of State.
6. In the Type drop-down list, choose String (this allows the column to contain alphanumeric values).
7. Setawidth of 10 (this is the number of characters which can be displayed in each cell).

2
Edit Schema
E] [R] #Area - | Name: Head_of State
5] Country Display MName: Head of State
[S] Capital Cancel
[R] Arable Pet Type: [S] 5tring -
Population ]
[R Pop_Grw Rt Size: 10 =
[R Literacy -
K Inflat Rote Default Value:
[R] Unempl_Rate Visible
[R] Indust_Grwth !
[S] Continent = || [ Read-only
[ pen_pattern [ Derive value from expression:
0 brush_pattem Expression: ]
Head_of State E ‘ & -

In certain instances, a default value for an attribute may be required. Setting a Default Value gives each record
the same value. Do not enter a default value for this tutorial.

8. Click OK to close the dialog box.
The new column is created and can be given values in the MAP Attributes panel.

9. Leave the document open for the next tutorial.
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3.3 Change an existing column's properties

5.

6.

42

Continue working with the previous tutorial.

If necessary, open the MAP Attributes panel and select all objects on the world_area layer.
Open the Edit Schema dialog box and select Capital in the attribute column list.

In the Display Name box, rename it to Capital City. Also, change the size to 30.

The column type may be changed after it is created (e.g. convert a type real column to a type integer column).
For this tutorial, leave the type as String. Also, any new polygons added to the world_area layer will have a

default value of None.

Leave the Visible check box enabled and the Read-only and Derive value from expression unchecked.

-
Edit Schema
(&) [ #Are p fene: Capta
=] 8] Country Display Name: Capital ity
Capital Cancel
[R] Arable_Pct Type: String A
[R] Population ) -
[ Pop_Grw_Rt Size: 30 :
[R] Literacy v
Inflat_Rete Default Value:
[Rl Unempl_Rate —
[B Indust_Gruth 1
[ Continent = || [] read-only
[ pen_pattern D Derive value from expression:
@ brush_pattern
5] Heatl of State Expression: 7 [@
L

Click OK.

The column is now renamed and its width is increased to accommodate longer names.

Leave the document open for the next tutorial.
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3.4 Create a new column using expressions

Continue working with the previous tutorial.

If necessary, open the MAP Attributes panel and select all objects on the world_area layer.
Open the Edit Schema dialog box.

Click Add to create a new attribute column called Annual_Increase and set the Type to Integer.

Check the Derive value from expression check box and click the Expression Builder button next to the Edit
Expression box.

N

Build expressions by making selections from the Objects list in combination with using the operators available
at the top of the dialog box.

5. In the Expression Components section at the bottom of the dialog box, double-click the Population column
in the Objects list, click the * symbol button, click the ( symbol button, double-click Pop_Grw_Rt column, click
the / symbol button, then type 100. Finally, click the ) symbol button to close the expression builder. The final
expression in the Edit Expression box is: Population*(Pop_Grw_Rt/100).

Expression Builder

[=famlledle) feliadlaisd
Population™( Pop_Grw_Rt/100) Cancel

[ Library...

o The expression is valid. Position: 28

) Expression Components

Objects Description
Country «| Pop_Grw_Rt
Capital
R Arable_Pct Type: Real
B Population Size: i
B Pop_Grw_Rt Default Value: 0.0
[ Literacy
[ Inflat_Rate Displa unigue values
R Unempl_Rate
B Indust_Grwth
Continent
[ pen_pattern
[I] brush_pattern e

[ |

L

The expression is valid statement means that the expression syntax is correct and can be performed.

6. Click OK to close the Attribute Expression Builder dialog box
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Edit Schema

(] [BI Country | Name: Annual_Increase

4 Capital Display Name: Annual_Increase
[R] Arable_Pct Cancel
[R] Population Type: [T Integer -
[R] Pop_Grw_Rt
Literacy

[R] Inflat_Rate

Rl Unempl Rate ||| Default Value: 0 :

R Indust_Grwth o

Continent

I pen_pattemn = Read-only

[ brush_pattern Derive value from expression:

:::;TFI*:::;E Expression: n*( Pop_Grw_Rt/100) Fi
S « The expression is valid.

The expression box is populated with the expression that was just created.

7. Click OK again to close the Edit Schema dialog box.
The Annual_Increase attribute column is updated with values calculated from the expression. Notice that these
calculated values are grayed out. They can only be edited by modifying the attribute expression.

“

LN >

MAP ATTRIBUTES
Layer: | Bl world_area (220 areas selected) -]
[RlUnempl_Rate [RlIndust_Grwth [§]Continent [S|Head of State  [[]Annual_Increase =
1 320 00 62 Asis - 855415 L
2 00 0.0 0.0 Europe o 60,030
3 00 26.0 09 Africa o 650,554
4 00 00 0.0 Europe =
5 2132 0.0 0.0 Africa o 2
6 45 50 0.0 North America o 41|~
< mn ] »
K[< wore [ [
220 reas somced EOmEE

8. Close the document without saving.
3.5 Join tables

Create a new Adobe Illustrator document.
Import canada.shp from the Tutorial Data folder.

Open the MAP Attributes panel and click the Join Table button at the bottom right of the panel. ¥

Make sure the Data Type is set to Files (ASCII, Excel, Sdts, Dbf)*, click Browse next to the Dataset Name box and select
CA_commute.csv from the Tutorial Data folder.

5. Check the First line contains column names check box and Choose NAME from the Matching Column drop-down
list. Leave the schema specifications character encoding at their default values. Since there is only one MAP
Layer in the MAP View, the Destination Target Layer will default to canada_area.

HwoN =

*The Data Type drop-down list is not available on Mac.
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6. The Matching Column drop-down list shows attribute columns of the same type (String) from the target layer to
base the join on. Set the matching column to NAME.

r ~
Join Table
soree o
Data type: [Files (ASCIL, Excel, Sats, Dbf) B
Cancel
Dataset name: torial(Tutorial Data/CA_commute. csv Browse...
Mame: CA_commute -
Matching column: [ [S] NAME -
First line contains column names
Character encoding: |System =
Destination:
Targetlayer: canada_area [A]
Matching column: NAME =
Options:
[7] case sensitive when matching
[ Add matching column from source
[ Update existing columns instead of adding columns when possible
L )

7. Make sure that the dialog box matches above and click OK.

Layer: | I canade_ares (1 woens seecied) o] [=]
oot Sl mrexn Weormn W00 @Cm o HCmefothc Bomevel  Ecmt oo WCmOme 0 °

8 [EAE | uneat S nm 185103 2888 1 S0 1 1380

1A Morthwest Testone B s 1882085 105 = 5480 a L5

3 CALZ Wk Tetory BET 55 mm 160 a f) s -]

4 CM Brish Columbi 190,78 Az e S8 LR 158150 mHe nIm TEn

5 CAll Abei Tomamr LT MINT LA 195,080 was Er s

& Call  Sekatchewss Lt L3I LW 1610 L] 00 £455 707

7 003 Munkska 1119483 LzmaL S ELE 2508 £ £ w0

) CH8 Owaes LA 1120867 ST A0S 0 200 805 e

3 CAD  Quebec 14T 7.507.375 FETIE I T ) a5 0380 wa 0

1 CHM  Hew Brunowick THE8 ™I L] s a5 5 s 5400

I CAT  Hows ot oonoor L LM B 108 nam 2824 a5

12 CA  Prince fdward hiand i L8 5880 ho0s s 4050 e s

13 CE03  Mewdcundland and Labeator si9m 001% A 18T g 10840 s num

13 aveas selectnd 3]k

8. Scroll to the right to view the joined attributes. The imported table is joined with the attribute table of canada.shp.
9. Close the document without saving.
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4 Plotting Points

See User Guide, Chapter 6
4.1 Plot points in decimal degree and degrees-minutes-seconds formats

1. Open usa48.ai from the Tutorial Data folder.

This document contains the conterminous United States. The polygons are on the usa_area layer, in a MAP View

named usa. The specified coordinate system is United States: Albers Equal Area, meter.

2. Inthe MAP Views panel, click the Add MAP Layer button. In the Add MAP Layer dialog box, rename Layer 1 to
cities, set the Feature type to Point and click OK.

Add MAP Layer
Layer name: dties
Feature type: P Point - l
Advanced:
[ Base attribute schema on: | [&] usa_area

Check this option to inhesit the attribute structure from the specied kayer.

w

Open the Adobe Illustrator Symbols panel (click Window > Symbols).
4. Inthe Symbols panel option menu, click Open Symbol Library > MAP Symbols > MAP - Symbols. If using a

non- English version of Illustrator browse to Open Symbol Library > Other Library and load MAP Symbols.ai from the

\Helpful Styles & Symbols\MAP Symbols folder (see page iii).
5. Choose some city symbols in the Map Symbols panel and drag them to the Adobe Illustrator Symbols panel.

MAP SYMBOLS SYMBOLS
= DI i
A

S
A
=

6. Inthe MAP Views panel, select the cities layer.

7. Open the MAP Point Plotter panel (choose Window > MAPublisher > MAP Point Plotter) or click the MAP Point
Plotter button on the MAPublisher toolbar. §

8. To change the plot symbol, click the symbol and select MAP Symbol 03. Leave the Scale set to 100%

9. Set the Input Coordinate System to Use: WGS 84.

10. Ensure that Decimal Degrees (D+[.d*]) is chosen in the Format drop-down list.

11. To plot a point for Los Angeles, type -118.4183 in the Long box and type 34.1151in the Lat box. Click the Plot
button to plot the point on the map.
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Currant Layer

P cies

Display
Scale: |2 100% -

Symbol: @) | MAP Symbol 03

Input Coordinate System:

(@) Us=: WGS 84

Coordinates:

Leng: -118.4183
Lats 4.1151

MAP POINT PLOTTER

United States: Albers Equal Area, meter

(7} Use Current Layer's coordinate system

Format:  Decimal Degrees (D+[.d*])

deg
deg

A point is plotted at the location of Los Angeles (34.1151 degrees north, 118.4183 degrees west).

12. Choose Delimited Degrees Minutes Seconds (D+dMM'SS[.s*]") from the Format drop-down list.
13. To plot a point for New York City, type 73d56'39.0"W in the Long box and 40d41'14.0"N in the Lat box.
14. Click the symbol text name to select a symbol style, change the Scale to 150% and click Plot.

A point is plotted at the location of New York City (40 degrees, 41 minutes, 14 seconds north and 73 degrees, 56

minutes, 39 seconds west).

15. Finally, plot a point for Chicago. Type 87d41'18"W in the Long box and 41d50'21"N in the Lat box. Alternatively,
change the Format back to Decimal Degrees (D+[.d*]) and type -87.6883 in the Long box and 41.8392 in the Lat box.

MAP POINT PLOTTER

|| current Layer

P| cbes

Display.
Seaks |21 150% v

| Input Coordinate System:

19) Use: WGS 84
Coordinates:
Longs  g7da11Ew

Lat: HdS021"N

Symbol: (@ | MAP Symbol 03

United States: Albers Equal Ares, mater

(7 Use Current Layer’s coordinate system

Format:  Delimited Degress Minutes Seconds.. w

deg
deg

7 @ =

|/ [Non-MaPp layers]

MAP VIEWS

1 MAP View

o @l s 3

Tiayers

All the points are plotted on the map. Experiment with plotting your own points, using different symbols,
coordinates, coordinate systems and data.

16. Keep the document open for the next tutorial.
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4.2 Plot centroids

Continue working with the previous tutorial.
1. Choose Plot Centroids from the MAP Point Plotter panel option menu.

Plot Centroids

MAP View: [@ usa .] [ oK ]
Source layer: [ usa_area -
Destination:

©) Eisting layer: | P cities -

@ Mew layer: centroid P

This layer will inhertt the source layer's attribute schema,

Options:
Style: @ MAP Symbol 03 -
Scale: 150 % =

High accuracy (slower, forces centroid within area boundaries)

The MAP View and Source layer are already set in the Plot Centroids dialog box. The Destination is already set to
be a new layer called centroid. This creates a new destination layer and places the points on this layer.

2. Change the Style to MAP Symbol 02 and change its scale to 50%.
3. Leave the other options as default and click OK to close the dialog box.

Points are plotted for the centroid location for each state polygon.

4. Close the document without saving.
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5.1

HwnN =

ow

5 Drawing with MAPublisher

See User Guide, Chapter 7

Create shapes with specific map dimensions

Create a new Adobe Illustrator document.

Import fsatoronto.mif and import torontostreets.mif from the Tutorial Data folder.

Transform the coordinate system of the fsatoronto MAP View to NAD83 /UTM zone 17 (see Tutorial 2.9).

Zoom to an intersection of these streets. A recommended zoom level is 600%.

To construct an imaginary building at precise map dimensions

In the MAP Views panel, add a new MAP Layer called Buildings and specify it as an Area feature type.
In the Adobe lllustrator Tools panel, click the MAP Area Plotter Rectangle Tool button.
In the Adobe lllustrator Layers panel, make sure the Buildings layer is active. Click once near the intersection of

the two selected streets to open the Area Plotter dialog box.
Type 50 into the Width box, type 30 into the Height box, check the Center area on click check box, and click OK.

Area Plotter

Target: l [A Buildings

e ]

o

() Page coordinates (Glabal Rulers)

@ Word coondinates:
Coordinate system: NAD83 /UTM zane 17N
[F] use: wiGs a4
Input format:  |Projected units -
Options:
s
Location type:

o X 630,184.315424 m ﬂ
o Vi 4835452919412 m
Size:

Units: [ Mater -

Width:  50.000000000000000 m T
Height:  30.000000000000000 m =

[7] Constrain dimensions
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Since the fsatoronto MAP View is in UTM, the units are displayed in meters. These settings create a rectangle
50 x 30 meters. The center of the polygon locates at the single-click point from the previous step.

9. Move the building to the southeast corner of the intersection. Rotate it so that it is parallel to College St. using
the Rotate Tool. Give the building a fill color.

Presume that this building is an established grocery store. In a recent survey it was found that on average, the
majority of its customers lived within 500 meters of the store.

10. In the main Adobe Illustrator Tools panel, click the MAP Measurement Tool. < Click the center of the building
rectangle and move the cursor outwards until the distance is about 500 meters.

The MAP Measurement Tool displays a distance of about 500 meters. This helps to approximate a distance of
500 meters around the grocery store. To measure multiple straight sections, hold the Shift key and click.
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11. In the main Adobe lllustrator Tools panel, click the MAP Area Plotter Rectangle Tool button (Alternatively, click
and hold the button to choose the MAP Area Plotter Ellipse Tool). Single-click in the center of the building to
open the Area Plotter dialog box.

12. In the Options section, type 1000 for both the Width and Height (or click the Constrain Dimensions check box).
Make sure the Shape is an Ellipse and the Point is Center. Click OK.

Options:
-
Lot e

o X 630,182.724625 m
 ¥: 4,835,603.456861 m (i85
Size:

Units: [ Msser -

Width:  500.000000000000000 m =

Height: | 500.000000000000000 m

A 1000 meter diameter circle (500 meter radius) is placed around the grocery store and shows where the
majority of customers live. The circle can be selected and styled like other area and line elements.

13. Close the document without saving.
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6 Cropping with MAPublisher

See User Guide, Chapter 7
6.1 Crop data with MAP Vector Crop Tool

1. Create a new Adobe lllustrator document.
2. Import torontostreetsjoined.mif and fsatoronto.mif from the Tutorial Data folder.
3. With all data on both layers selected, open the MAP Attributes panel.

I

LN x

MAP ATTRIBUTES
Layer: | [ featoronto_area (19 areas selected) ) [+
FSA M Aprtmnt_cnt  [T]Bus_cnt [MIFarm_cnt [MHse_cnt [RlArea_kmsq
1 MY 25450 3260 0 4257 1142530000 ‘z ‘
2 MsB 36 1,267 0 0 0516775000 —
3 MsC 17,690 5,397 0 3,260 0.190753000
4 MSE 724 2011 0 0 0474701000
5 MsG 169 965 0 0 0645136000
6 MsH 35 743 0 0 0010545300 -
o 0 ] )
Hj4 oof 13| b |1
19 areas selected =l @@@

Examine the table structure and map attribute records. Deselect the data and close the MAP Attributes panel.

4. Click the MAP Vector Crop Rectangle Tool from the main Adobe Illustrator Tools panel.
Notice the mouse cursor has changed to a cross hair.
5. Click once near the center of the map. This opens the Vector Crop dialog box.

6. In the Size section, enter a width of 0.025 and a height of 0.045 (degrees). In the Target section, choose Only and
choose the fsatoronto_area layer in the drop-down list.

MAP Veetor Crap
Input: Target: =]
TS ol rand Alllayers i document | e
& okt coordinates: | @ fratoranto =) : — L
.oy 2 Mlresie: | @ hatreni -
Cooedrate system: WG5S 34 |
Ve Wi 54 ® onbvi | featoranto_sea [ttt
et tomat[Dacnelderses DT J T
Dptiona:
Sage: |Rectangie

Locsen type: [Postion =
port [Ecemer  w
o longi PR

i¥
—

o Lak anES03
Sires

e (B z
Width;  5.025000000000000 dey

Heghts 0.045000000000000 deg

Cormt v

Move the dialog box out of the way to see a preview of the crop area size. This will give you an idea of what
section of the data will be cropped. The crop should only target fsatoronto_area layer and the streets will
remain untouched.

7. Click OK to complete the crop.
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The fsatoronto_area layer is cropped to the crop extent and the streets were untouched because they were not
included as a target.

8. Inthe Adobe lllustrator Tools, click and hold the MAP Vector Crop Rectangle Tool button to choose the Ellipse
Rectangle Tool. On the artboard, click and drag an ellipse to draw a crop extent. Release the mouse button to
complete the crop.

Note: To achieve a proportional crop area, hold the Shift key while dragging the crop area.

9. Once again, select all data in both layers and open the MAP Attributes panel.

MAF ATTRBUTLS

wrpers | I featoronto,_sems (8 sres ieciec) =] [=]
irsa MAprimnt_cnt [ Dus_crt MFamcnt  WiHoecnt BlAsesbmzg [
1 MY Ba% 1368 [ 435 LI4350000
2 M £ L7 ] L] 016778000 |
3 M5G 18 65 [} U DAEHSLIS00
4 M a3 138 o 0 3553310000
5 MST 288 58H [} 2568 L5IS000
o o 3510050000 o

6 MY 432 53

Notice that the attributes have been maintained, but there are fewer features because of the crop.

10. Close the document without saving.
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7 Art and Line Functions

See User Guide, Chapter 8

7.1 Buffer art using an entered value

1. Create a new Adobe lllustrator document.

2. Import burlroads.mif from the Tutorial Data folder and assign NAD83 / UTM zone 17N as the source coordinate system.
Navigate to the location, Projected > UTM > NAD83 to find the coordinate definition (Tutorial 1).

3. Select a few lines to be buffered.

4. On the MAPublisher toolbar, click the Buffer Art button % or choose Object > MAPublisher > Buffer Art.

5. In the Buffer Art dialog box, click the Only buffer selected art check box. Under the Buffer Width section, choose
the Static Value option, in the Units drop-down list choose Meter, and type 25 into the adjacent box. Under the
Destination section, choose the New Layer option and type Line Buffers into the box. Leave the default setting to

dissolve results.

Buffer Art

Layer: [ I burroads_line

Only buffer selected art

Buffer Width:
@ Staticvalue:  25.000000

© Attribute value: | [R] #Dashoffset

Destination:

Existing layer

@ New layer: Line Buffers

Options:

Dissolve resuits

[Z] Apply style: B stoke: | [7] INone]
Fill: [/ None]

Add concentric crdes every:  |0.000000

This layer willishert the source layer's attibute schema

Cancel

A static value of 25 meters represents a buffer value of 12.5 meters on either side of the selected roads.

6. Click OK to apply the buffer art settings.
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The lines that were selected for buffering now have a buffer around them on a layer called Line Buffers.

Buffered lines can be styled like any other object. Try this to make them stand out from the roads.

Alternatively, a Graphic Style can be chosen in the Buffer Art dialog box so that a style is automatically applied
to the newly created buffer.

7. Close the document without saving.
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7.2 Fliplines

There are two methods in MAPublisher to ensure that text labels are oriented correctly when they are attached to
paths. The first is to check the Reverse right to left paths (flip upside-down text) option in Label Features or the MAP
Tagger Tool. Alternatively, permanently correct any digitizing irregularities by using the Flip Lines function.

1. Create a new Adobe lllustrator document.

2. Import torontostreetsjoined.mif from the Tutorial Data folder.

3. Select the two lines as indicated in the graphic below and add arrowheads to the lines by choosing Effect >
Stylize > Add Arrowheads in CS4. In lllustrator CS5 the Add Arrowheads controls have been integrating into the
Stroke panel, which can be found at Window > Stroke.

Add Arrowheads
Start: OK
[TlPreview
a—  None —»
End:
este _ —
[—] 1of27 ==
LT e UL = =
Srale %

WO =y
N S
o
e

Arrowheads are added to the selected road lines.

5. Onthe MAPublisher toolbar, click the Flip Lines button. <«
Notice how the selected lines now have their beginning and end points switched (as indicated by the
arrowhead). The orientation of the lines are permanently corrected. Any labels placed along these lines are now

oriented correctly (labels would be oriented below the lines if the lines were not flipped).

6. Close the document without saving.
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7.3 Join lines based on attribute value

1.
2.

Now &

Create a new Adobe lllustrator document.
Import torontostreets.mif from the Tutorial Data folder.

Select individual line segments to see that lines are not joined with other line segments, even though the line
may be of the same street.

Select all objects on the torontostreets_line layer.

In the MAP Attributes panel, notice there are 1197 line segments in the torontostreets_line layer.

On the MAPublisher toolbar, click the Join Lines button.

Make sure that torontostreets_line is selected as the Target Layer. Leave join lines on target layer selected.

Under Destination choose the Copy result to new layer option and enter the layer name Joined Streets.

Under Join Options, leave the Only join lines with shared values from option checked and choose the Street
attribute from the drop-down menu.

Type 0.01in the Proximity box and make sure the proximity unit is set to Degree. Proximity is the tolerance setting
used in the join process.

Ensure the Close Segment Gaps check box is unchecked.

Target Lover: | L mrrerers e

it e gt

Iam e
- o =
o st g

) ot i . s | S

o o s
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10. Make sure that the dialog box matches the one above and click OK.
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A new layer called Joined Streets is created and contains 264 line segments (according to the MAP Attributes
panel). The original dataset contained 1197 line segments. Select an individual line segment and notice that the
line is joined with line segments that share the same street name (the attribute the join was based on).

11. Close the document without saving.

7.4 Simplify lines

1. Create a new Adobe lllustrator document.

2. Import the ukrail.gen file from the Tutorial Data folder and specify British National Grid as the coordinate system. It is
located under Projected > Europe > United Kingdom.

3. Select all objects in the ukrail_line layer and click the Simplify Lines button on the MAPublisher toolbar .

4,

In the Simplify Lines dialog box, type 2000 in the Proximity box and choose Meter in the Units drop-down list.
5. Click Preview to see a preview of the simplified data with the current settings.

-
Simplify Lines Simplify Lines

Proximity: 2000,000000 | | Meer - oK Proximity: 2000.000000 = | Meter - oK

Vertex Count: Vertex Count:

Original: 17186 > Original: 17186

Simplified: 0 Simplified: 8756 (50%)

= Usas Douglas-Paucker line simpification ® Uses Douglas-Peucker line smplfication

« Maintzins topology between arezs with shared edges « Maintzins topology between arezs with shared edges

6. Click OK to start the simplification process.

The selected lines are now simplified based on a proximity value of two kilometers (2000 meters) and have been
simplified from 17,186 vertices to 8,756 vertices or a vertex reduction of about 50%.

7. Close the document without saving.
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7.5 Join points

1. Create a new Adobe lllustrator document.

2. Import torontostreetsjoined.mif and torontopoints.mif from the Tutorial Data folder. After import, ensure the
torontopoints_point layer is positioned at the top of the layers hierarchy in the Adobe Illustrator Layers panel.

3. If necessary, deselect all layers and only select the points of the torontopoints_point layer and open the MAP
Attributes panel.

11N x

MAP ATTRIBUTES =
Layer: [ P torontopaints_point (133 points selected) v]
[MlLineNumber  [§]ID Sl Type [T] AreaNumber =
1 0 P43 Node 9 [
2 0 P43 Node 8
3 0 P43 Node 7
4 0 P43 Neode 6
5 0 P43 Nede 5
[ 0 P43 Nede 4
7 0 P43 Node 3 -
W[4 oof133] b |1
133 points selected @@@@

The ID attribute column contains four unique values identifying points that compose: two subway lines (51 and
S2), the mainline rail track (R1), and a park boundary (P43). The LineNumber and AreaNumber columns contain
rising numeric values indicating the number of each point in its sequence. Note that some points contain
matching values.

4. Deselect all points and on the MAPublisher toolbar, click the Join Points button.

Since only one point layer is present in the document and there are no points selected, the Source Layer
defaults to the torontopoints_point layer in the Join Points dialog box.

5. In the Destination Layer box, type Joined Points (a new layer will be created with this name) and leave the Close
paths check box unchecked.

6. In the Group By Column drop-down list, choose ID. This contains the unique attributes that will be used to join
similar points together.

7. Inthe Sort By section, click LineNumber in the Available Columns list, and click the right arrow button to add it to
the Sort Order list. Click AreaNumber and click the right arrow button again to add it to Sort Order.

Ensure that LineNumber is at the top of the Sort Order list box. Having LineNumber at the top of the Sort
Order column makes it the primary sorting column when determining the order of points in the chain. The
AreaNumber column is used as the secondary sorting column, if any points in the primary column contain
matching values.
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Join Paints

Source: oK
Layer: P! torontopoints_point - l

@ Alpoints ) Selected points

Destination:
Layer: Joined Points
[ Close paths

Group By:
Column: [ D -

Sort By:

Available Columns Sort Order

[R] #Pagex [ LineNumber
[R] #PageY M AreaNumber
I 21d
5] #Name »
[Rl #HorizontalScale ||
[R] #VerticalScale E
[R] #Rotation

8] #style -

»

n

8. Make sure the dialog box matches the one above and click OK.

All the points are joined based on the specified parameters. A line layer called Joined Points is created that
contains four new lines. The lines represent two subway lines, the mainline rail track, and the perimeter of a small
park. To see the Joined Points line more clearly, hide the other layers.
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9. Select the four lines of the Joined Points layer and open the MAP Attributes panel.

MAP ATTRIBUTES

Layer: | ILJ Joned Pornts (4lines selected) -
D B

] 4 uuf4|.- M

4 lines selected @@@

Notice that an attribute column named /D was created and contains the values specified in the Group By
Column setting in the Join Points dialog box. Note that the small segment with the attribute P43 is the outline of
a park area. However, this segment should be closed and should be deleted using the following steps.

10. In the Adobe Illustrator Layers panel, select the torontopoints_point layer and use the MAP Selections to select
all the points with an ID equal to P43 (see Tutorial 10 on Making Selections).
11. With the points of P43 selected, click the Join Points button.

In the Join Points dialog box, the torontopoints_point layer and Selected Points option are chosen by default.
12. In the Destination Layer box, type Park Area. This time, check the Close Paths check box. Leave the Group By

column as the default of ID.
13. Add AreaNumber and LineNumber to the Sort Order column list, and make sure LineNumber is at the top of the list.

Join Paints

Source: oK
Layer: P! torontopaints_point v]
©) Alpoints @ Selected points
Destination:
Layer: Park Area

Close paths

Group By:
Column: [ o] -

Sort By:
Avalable Columns Sort Order
R #Pagex

[ #PageY

I #1d

#Name

R #HorizontalScale
[R] #VerticalScale [«
[R] #Rotation -

[ LineNumber
M AreaMumber E]

»

>

14. Make sure your dialog matches the graphic above and click OK.
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The selected points are joined based on the specified parameters. A new Park Area layer is created that contains

a polygon that represents the perimeter of a small park. The map can be styled to more clearly show the subway
lines, rail line and park.

15. Close the document without saving.
7.6 Joinareas
1. Create a new Adobe Illustrator document.

2. Import worldd.mif from the Tutorial Data folder.
3. With the world layer selected open the MAP Attributes panel.

P IS Country 5 Comtinent [ antle Pt Ecpulation  Wrep Grakt  Rlinency
1 Kabul Adghanistan Asa 12000000000 16,450, 04,0000 5200000000 22000000
3 Twane Alanis Ewreps 200000000 3,535,044.00000... 1500000000 72000000
3 Mg Algeria Arica 000000000 26,072,185.0000... 1500000000 50000000
4 AndomalaVels  Andoms Eurpe 2000000000 33,157 10000000 2400000000 0.0000000
5 Luieds Angols Atries 2000000000 8,668,781.00000... 70000000 42.000000
6 Thevaley Anguika Mceth America 0000000000 6,922.000000000 0500000000 35.0000000
T oo Antarctica Antarctica 0.000000000 0000000000 0000000000 000000
&  Stlohns Antigua Harth A 0420000000 29000000
18 Beesfms  Angenting South Aenerce 9000000000 32653.983.0000... 1100000000 5000000
10 Veerian Amaenis Turspa 0000000000 T417,000.00000... 0.000000000 0.0000000
11 Oanens anba Heeth fenemen 0000000000 &4,052 (0000000 0.500000000 00000000
12 Caberea Augtrais Austraks 6000000000 17,785,044.0000_ 1300000000 100.000000¢
13 Wienna Austna turpe 17000000000 7,565,504 00000... 0300000000 590000000
18 Bak Arerbsijan Europe 0000000000 | &311,000.00000... 0.000000000 00000000
15 FPontaDelgads  Azores Lurope 0000000000 0000000000 0000002000 0000000
220 areas sekected ia) (73] [ lgti] el

Notice that the Continent column holds the contient entry for each country. This is the attribute that you will
join areas with.

4. Deselect all art by going to Select > Deselect in the file menu. On the MAPublisher toolbar, click the Join Areas
button £
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Since only one are layer is present in the document and there are no areas selected, the Source Layer defaults to
the world_area layer in the Join Areas dialog box.

5. Under Destination, choose the Copy results to new layer option and type Joined Areas (a new layer will be created
with this name).

6. Under Join Type, choose the Join areas by attribute option and choose Continent from the drop-down menu.

7. Leave all attributes set to Clear if different when joining. Notice beside Continent it states "Join on". Click Ok.

e — = fy
Target Layer: | [ word_area = Attnbetes: =]
fe— ==
& 1o oo ey 5 Capital Clear if cifferent N/A
B Copy resudte 1 e layer: e Arant 5l Country  Clear if Gifferent WA
f Bl Continest  Joun on A
Join Type:
€4 Ty ol electad armas o target ayer B asable Pct  Clear if chfferent N/& I
® Jonareas by strbute: | 5] Contnent. ][RI Pepulsticn  Clasrif Sffarent WA
= )
2] oriy joes scected areas B Pop Grw. Rt Clear il different /A
Bl Literacy  Clear if cifferent Hid
Join Method: :
) Groun arees B nflae fate  Clear if hfferens WA
@ Creste compound areas. B Unempl Fate Clear if different N/
1 et Tt Reeu Asbwos v e ] Indust Grath Claar f different NIA

I penpatteen  Cloar if different Ni&

[0 brush_patcern Clear if different /A

@ gty 1o ey griped component
1) Cky apply 1o grongpad componanas St easefy:

(B Erpty sxpresmon. In possen: O

New areas have been created based on matching Contient attributes and the boundaries of counties of have
been dissolved.

8. Close document without saving.
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8 MAP Themes and Legends

See User Guide, Chapter 9
Create an area stylesheet theme

Create a new Adobe lllustrator document.

Import world.mif from the Tutorial Data folder.

In the Adobe lllustrator menu, choose Window > Graphic Styles to open the Graphic Styles panel.

In the Graphic Styles panel option menu, choose Open Graphics Style Library > MAP Graphic Styles > MAP - Area
Solid Colors. For non-English installations of lllustrator choose Open Graphics Style Library > Other Library and load
MAP - Area Solid Colors.ai from the \Helpful Styles & Symbols\Graphic Styles folder (see page iii).

Shift-select all the graphic styles in the MAP - AREA SOLID COLORS panel and drag them into the Adobe
lllustrator Graphic Styles panel.

MAFP - AREA SOLID COLOURS

GRAPHIC STYLES GRAPHIC STYLES

b

[ |
EEE
&,

Open the MAP Themes panel (choose Window > MAPublisher > MAP Themes) or click the MAP Themes button on
the MAPublisher toolbar.

AP THIMIS

© MAP Thame = I 3

In the MAP Themes panel option menu, click New MAP Theme.
In the New MAP Theme dialog box, type Continents1into the Theme Name box, choose Stylesheet as the Theme
Type, choose Area from the Feature type drop-down list, and click OK.

Hirw MAP Theme

e Carrriad =
These tioe: | i Styestest =
Theme Dptue:

Featee toe: | Area =

o Do o o T b 5 o S

Double-click Continents1 stylesheet, or choose Edit "Continents1" from the MAP Themes panel option menu.

Click the Layers icon and choose the world_area layer. In the Edit Stylesheet Theme dialog box, click the
plus symbol to add a style rule. Rename Rule 1 to Africa.

Under Expression, click the Expression builder/Simple expression toggle icon to view simple expression
mode with its three drop-down menus in the first row.

Use the left-hand drop-down list to set the attribute to Continent, select the equal sign for the operator, and
select Africa from the right-hand drop-down list as the attribute value.

Under Apply Properties click the Style check box and choose a graphic style from the list of styles previously
loaded into the document.
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Edit Styleshest Theme
Theme name: Continents1 Never reset visual properties
Layers: world_area (© Generate Rules... | | 4l Edit Rule Ramps..
rutes: (9] [0
& | [ Afiica Mame:  Afiica
= Stop applying rules if art qualfies for this rule
Expression:
[§] Continent - | - | Africa -
-
Expression: Continent = "Africa”
Apply Properties:
Style: [ MaP Area 27 -
[ stroke: [ teme) A

11

Cancel

13. Leave the other display properties at their default values and click Apply to see the changes made to the map.

Note:

If changes are made to a style, click white empty space in the dialog box before clicking the Apply button.

14. Repeat steps 9 to 11 for each of the subsequent continents. Note that the same style cannot be used more
than once, as one style equals one legend entry. When all of the continents are assigned a style, click the Apply
button to see the changes, or click OK to close the dialog box.

Edit Stesheet Theme

Theme name:  Cortnental

Hiewer rescl vl orecerien

] tayers: wor peea 3 Generate fukes..| | 4l £t Rule Rams. |
=
friex eae
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v | Y, ek 91 5tom spptymg ndes  art qualies for i e
o A
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o Euope Expression: -
" North America I8 Contrerit v = x| Seuth America v [fe]
o Ocearia =
Expreson: Contrmnt = “South Aeerca®
Apoly Propertics:
[ stre: | e e 16 ~] [
Siroke: T i) v

0
i
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9

The styles specified have been applied to the map. The styles in the Graphic Styles panel are now linked to the
attribute values specified by the style rules.

15. Save this document as MyWorld.ai in the Tutorial Data folder. It will be used again in Tutorial 8.4.
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8.2 Create aline stylesheet theme

HwnN =

6.

Create a new Adobe lllustrator document.

Import festreets.mif from the Tutorial Data folder.

Open the Adobe lllustrator Graphic Styles panel.

Use the Adobe lllustrator Line Segment Tool to create a graphic style by drawing a line on the page. Assign the
line a stroke weight of 2 pt, a stroke color of red, and a fill of none.

Open the Adobe Appearance panel via Windows > Appearance. From the Appearance panel option menu
choose Add New Stroke. Set the color to yellow and the stroke weight to 1.6. Make sure the newly created stroke
is above the 2 pt red stroke in the Appearance panel.

APPEARANCE

[ ] moselection

® [botroke: [ 1spt
=

=

=

[=]

botroke: [l 2t
I Fill:

‘Opacity: Default

o f= ® o #

Use the Selection Tool to drag this line into the Graphic Styles panel. In the Graphic Styles panel, double-click
the style to open the Graphic Style Options dialog box. Rename the style to Primary Road.

GRAPHIC STYLES

5]

Primary Road (Alt-click to add to existing style.
Right-click for larger preview.)

G. == 4l ¥

Delete the line on the artboard (the style will remain available inside the Graphic Styles panel).

7.

66

In the Graphic Styles panel option menu, click Open Graphic Style Library > MAP Graphic Styles > MAP - Line Styles.
If using a non-English version of lllustrator, choose Other Library > Open Graphic Style Library and browse to the
MAPublisher supplied file MAP - Line Styles.ai from \Helpful Styles & Symbols\Graphic Styles folder (see page iii).

Add the graphic styles MAP Line 12 and MAP Line 16 from the MAP - LINE STYLES panel to the document's
graphic style panel by Ctrl-clicking the two styles and dragging them to the graphic style panel. These new
styles will now be available for use in the current document. Double click each of the newly added graphic
styles to rename them. Rename MAP Line 16 to Secondary Road and MAP Line 12 to Local Road. Close the MAP -
LINE STYLES panel.

Open the MAP Themes panel and in the panel option menu, click New MAP Stylesheet.

. In the New MAP Theme dialog box, type Road Types into the Theme Name field, choose Stylesheet as the Theme

Type, choose Line from the Feature type drop-down list, and click OK.

AP THEMTS

[ nona rom

[ETTI— E v G 3
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11. Double-click the Road Types stylesheet, or choose Edit "Road Types" from the MAP Themes panel option menu.
Click the Layers icon and choose fcstreets_line layer.

12. In the Edit Stylesheet Theme dialog box, click the plus symbol three times to add three rules. Rename Rule 1
to Primary Road, Rule 2 to Secondary Road, and Rule 3 to Local Road.

13. Under Expression, click the icon to toggle from the default advanced mode to simple mode.

14. In the Expression field, for the Primary Road rule select "Number" from the pull down menu displaying
attributes, and choose the unique attribute value "A25". Under Apply Properties, check the Style check box and
choose the Primary Road style.

15. In the Expression field, for the Secondary Road rule select "Number" from the pull down menu displaying
attributes, and choose the unique attribute value "A31". Under Apply Properties, check the Style check box and
choose the Secondary Road style.

16. In the Expression field, for the Local Road rule select "Number" from the pull down menu displaying attributes,
and choose the unique attribute value "A41". Under Apply Properties, check the Style check box and choose the
Local Road style.

Edit Styleshoet Theme.
Theme mame:  Road Types Hever reset vl oreoeres oK
] Lavers: festects ine b D Generate Rudes...| | ol £ e R e
Rules: .J - i .‘

] | v Primary foad Nawe:  Local Road
o Secondary Enad

N oo

| Stop applying rules & art qualfies for this rule.

Lxpression:
51 hiaber - | A e
|
Expression: Number = "Ad1" + |
Apply Properties:
7] sy Locl e | [

17. When all the rules are defined with a style and expression, click Apply.

18. Save this document as MyRoads.ai in the Tutorial Data folder. It will be used again in Tutorial 8.6.
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8.3 Create a point stylesheet theme

10.

68

Complete Tutorial Guide exercise 1.6 or open MyPoints.ai in the Tutorial Data folder.

Open the Adobe lllustrator Symbols panel (choose Window > Symbols), in the Symbols panel option menu,
click Open Symbol Library > MAP Library > MAP Symbols > MAP - Symbols. If using a non-English version of Adobe
lllustrator choose Open Symbol Library > Other Library and load MAP - Symbols.ai from \Helpful Styles & Symbols\
MAP Symbols (see page iii).

Shift-select all the symbols in the MAP Symbols panel, and drag them into the Adobe lllustrator Symbols panel.

SYMEOLS

oo E v @e

_ | (=)=} O |m==0
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Open the MAP Themes panel and in the panel option menu, click New MAP Theme.
In the New MAP Theme dialog box, type Point Data into the Theme Name field, choose Stylesheet as the Theme
Type, choose Point from the Feature type drop-down list, and click OK.
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Theme Dptue:
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o Dintiecis » F Moy b 2 8 e v

Double-click the Point Data stylesheet, or choose Edit "Point Data" from the MAP Themes panel option menu.
Click the Layers icon and choose azdeci_point layer.

In the Edit Stylesheet Theme dialog box, click the plus symbol four times to add four rules. Rename Rule 1
to Airport, Rule 2 to Church, Rule 3 to Hospital and Rule 4 to Park. In the Expression column, build the expression: (3
="airport" and under Apply Properties, check the Symbol check box and from the drop-down list choose MAP
Symbol 34 (airplane symbol). Check the Scale check box and change the Scale to 70%.

Select the Church rule and in the expression column, build the expression C3 = "church". Under Apply Properties
heck the Symbol check box and from the drop-down list choose MAP Symbol 29 (church symbol). Check the Scale
check box and change the Scale to 70%.

Select the Hosptial rule and in the expression column, build the expression C3 = "hosptial". Under Apply
Properties check the Symbol check box and from the drop-down list choose MAP Symbol 20 (Hospital symbol).
Check the Scale check box and change the Scale to 70%.

Select the Park rule and in the expression column, build the expression C3 ="park". Under Apply Properties
check the Symbol check box and from the drop-down list choose MAP Symbol 70 (Park symbol). Check the Scale
check box and change the Scale to 70%.
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11. Click Apply. The specified symbol styles are applied to the map. The styles used in the Symbols panel are now
linked to the attribute values specified by the style rules.
12. Close the document without saving.

8.4 Generating stylesheet theme rules

Create a new Adobe lllustrator document in landscape orientation.

Import world.mif from the Tutorial Data folder.

In the MAP Themes panel option menu, click New MAP Theme.

In the New MAP Theme dialog box, type Population into the Theme Name box, choose Stylesheet as the Theme
Type, choose Area from the Feature type drop-down list, and click OK.

HwnN =

b MAP Theme
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5. Double-click Population stylesheet, or choose Edit "Population” from the MAP Themes panel option menu.
Click the Layers icon and choose the world_area layer.
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7. Click the Batch Generate Rules button to open the Rule Generator dialog box. Under Source: choose be sure that
the world_area layer is selected. Choose Population from the Attribute drop-down list.
8. Click Load to generate rules. Rules are produced using the default values of 5 classes using Equal Intervals.
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9. The Natural Breaks Jenks-Caspall method offers a more mathematically rigorous classification. Click the Method
drop-down list and change Equal Intervals to Natural Breaks Jenks-Caspall.

10. Under Visual Property Assignment click the Set fill icon and choose a color ramp from the drop-down list.
Available color ramps are those loaded into the lllustrator Swatches panel.

11. Click Add to close the Rule Generator dialog box, and back in the Edit Stylesheet Theme dialog box click Apply.
Your map has now been stylized based on your generated rules.

12. Close the document without saving.
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8.6 Create a bar chart theme

1.
2.
3.

Create a new Adobe lllustrator document.

Import canada.shp from the Tutorial Data folder.

In the MAP Themes panel option menu, click New MAP Theme. In the New MAP Theme dialog box, type
Population into the Theme Name box, choose Chart as the theme type.

[ tarwe a2 Freemma

Theme rame:  Fopudaton o
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Double-click Population Chart theme in the Themes Panel. Click Yes when the alert box asks to create the
required Legend layer.

In the Edit Chart Theme dialog box, choose Bar Chart from the Type drop-down list.

Check the "Ignore" check box and enter in the following expression: LIKE(NAME,"Yukon") OR LIKE(NAME, 'Nunavut") OR
LIKE(NAME,"Northwest Territories"). This will prevent bar charts from being applied to Canada's far north.

In the Source Data tab, with canada_area selected in the Layer drop-down list, click the Add button @ twice to
add two attributes.

Highlight the first unspecified attribute. In the Attribute drop-down list, choose POP2001. In the Appearance
section choose a fill color and set the stroke to None.

Repeat these steps with the second unspecfied attribute highlighted, this time using the POP2010 attribute and a
different color for the chart bar (and no stroke).
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10. In the Chart Options tab, change the bar thickness to 10, the maximum bar length to 80, the bar spacing to 4.

Sercelam | ChwtCotors | GeneraiCpsions | Tite | Lahels
i thickness: wop &

Muomumberlengtt  800m

Bar orienaation: divertcsin v

D spcng: e

Baheghtreatve e [Chartmanyake v

11. In the General Options tab, click the Draw chart border check box.
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12. In the Title tab, click the Show title check box. Enter Pop as the title in the Specify box.

SouceData | ChartOpbons | GeneralOpsons | Tite | Labels

¥\ Show title
spoeerance: [ oo ok 220000
& specty g
From attiaie: |5
Algrmen | 8 Men cenier
P [ He

13. In the Labels tab, click the Show attribute value labels check box. Change the rotation value to 90 and click the

Appearance text style link.
14. In the Edit Text Rendition dialog box change the text size to 8.00 pt and click OK.
15. Click the Align value labels check box.
16. Click the Show attribute name labels check box and repeat steps 13 and 14.

SourceData | ChartOptions | GeneralOptions | Tite | Lobels
Show attribute value labels ‘Show attribute name labels
Appearance: [ 2ozl Black, 5.00 0t appearance: [ aialslack, 5.00 ot

Offset sopx [+ Offset: s.0px
Rotation: %0 % Rotation: 90
Displayed decmals: 0 [+

Align value labels

Label with pie percentage

17. Click Apply to apply the theme to the map.

18. Select the newly created charts and go to Object > Transform > Transform Each. Adjust the horizontal and

vertical scale to both 30% and click OK.

N

19. Close the document without saving.
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8.7 Create a pie chart theme

Create a new Adobe Illustrator document.

1

2. Import canada.shp from the Tutorial Data folder.

3. Join the table CA_commute.csv to the canada_area layer on the NAME column (see Exercise 3.5).

4. In the MAP Themes panel option menu, click New MAP Theme. In the New MAP Theme dialog box, type
Commuting into the Theme Name box, choose Chart as the theme type.

[ o Mt Freeme

Theme rame:  Fopaton o

These tyoe: |l Chart =

Now

o Dintiecit » b Mo i 2 8 o v

Double-click Commuting Chart theme in the Themes Panel. Click Yes when prompted to create a Legend layer.
In the Edit Chart Theme dialog box, choose Pie Chart from the Type drop-down list.
Check the "Ignore" check box and enter in the following expression: LIKE(NAME,"New Brunswick") OR LIKE(NAME,"'Nova

Scotia") OR LIKE(NAME,"Prince Edward Island") OR LIKE(NAME,"Newfoundland and Labrador"). This will prevent pie charts from
being applied to Canada's Maritime region.
8. Inthe Source Data tab, with canada_area selected in the Layer drop-down list, click the Add button || six times

to add six attributes to the pie chart.
Highlight the first unspecified attribute. In the Attribute drop-down list, choose Cmt_Drive. In the Label field,
enter Drive Own Vehicle. In the Appearance section, choose a fill color from the drop-down list or click the color

0

swatch to open the Color Picker dialog box.
10. Repeat step nine for the five remaining attributes choosng a unique color for each attribute and assigning
attributes and labels as follows: Cmt_Ride as Small Vehicle Passenger, Cmt_Public as Public Transit, Cmt_Walk as Walk,
Cmt_Bicycl as Bicycle, and Cmt_Other as Other.

Edit Chart Theme

| Tremerams: Commutng
Cutput tayee: | Q) Chart =
SorceDots | ghatCpene |
Laveri | [N canads_ares ~
|| [ ][ Drove Cowm vemicie

| E Small Vehiche Passenger

B #ubie Transt

Tipe: P chart -

] dgrere: o ware Indarad™) O LIGEUAME, Toamnfincland and Labrackn ] [,

T R AT

arwue: | [T Coe_Omer -
Lebel:  Other
Appearsnce:
(B e | I Sty coln
i | W =M= =0 K=G0

l® o s awme
= W% s

Dxplede: 000 |3

1 Shoe octusl size

e ]
Conced
Aeply.

11. In the Chart Options tab, change the Pie radius to 25.00.
12. In the Labels tab, click the Show attribute value labels check box. Set the offset to 3.0, click the Label with pie
percentage check box, and click the Appearance text style link.
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13. In the Edit Text Rendition dialog box, leave the font as Arial and choose Narrow as the text style and change the
font size to 8.00 pt.

SoaceOsts | ChartOptons | GenersOptors | foe | Laves

71 Shaw attribute vahie libeds Show attribute name sbeds
Agpeaarce; I i thornon 3,000 % % B
Offset: 105z

Oisplaped decmals: 0 (2

][ Lasb ith pt percentage

14. Click Apply to apply the theme to the map.

Note that some text labels, particularly the value labels for "Other" and "Bicylcle" attributes, will need to be
manually adjusted for optimal appearance. This is caused by small percentage values.

TR

= o
5
™

15. Leave the document open for the next exercise.
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8.8 Create achartlegend

1. Create a MAP Theme, Bar chart or Pie chart like those found in exercise 8.4 to 8.7. Click a Chart Theme in the

MAP Themes panel, open the MAP Themes panel option menu and click Create Legend.
2. Inthe Create Chart Legend dialog box, accept the default output layer.

Click the Label apperance text style link. In the Edit Text Rendition dialog box, leave the font as Arial, choose
Narrow as the text style, and change the font size to 10 pt.
4. In the Style tab, change the number of columns to 2.

In the Title & Border tab, click the Draw title check box and enter Commuting Modes. Click the Draw title line check
box and increase the margin to 8.00 px.

Create Chart Legend
Ouputiove: | O Chart = Create
Laboed sppmsrance: [ dvial bovrow, 10,0501 =
Stye | Tt hiborder
| | 11 oo e Commng o & Agp oo
scocarence: [l 2ol Boc, L2 00e
7] et e drnat
« Wl ® won = Lo f
¥) i 3
Privw border: - M ® e = oo

=| ] % [0

[[actud s

1 Show schusl sze

6. Click Create to create the Chart Legend. The Legend will be placed in the centre of the current MAP View, and
can be manually placed elsewhere on the document.

Commuting Modes

7. Close the document without saving.
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8.9 Create a dot density theme

HwnN =

Create a new Adobe lllustrator document.

Import southchinasea.shp from the Tutorial Data folder.

In the MAP Themes panel option menu, click New MAP Theme.

In the New MAP Theme dialog box, type Population into the Theme name box and choose Dot Density as the
Theme type.

b MAP Thame

Theme rame:  Fopaton (T

These type: | 1 Dot Dermty. -

o Dintiecit » b Mo i 2 8 o v

In the MAP Themes panel, double-click the Population Dot Density theme.

In the Edit Dot Density Theme dialog box, choose POP_ADMIN from the attribute drop-down list. Click the Load
button to view the attribute's data range. Notice that the low end of the range contains negative values.
Enter a dot value of 25000.

Leave the Dot Options at default values and click Apply to create dot density theme.

Click View Log in the MAPublisher alter box. Notice that three pieces of art were not stylized as they held
negative values in the POP_ADMIN column. Close the MAP Theme Log dialog box.

L

10. Close the document without saving.
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9 Labeling Functions
See User Guide, Chapter 10
9.1 Generate labels for a line layer using Label Features

1. Create a new Adobe Illustrator document.
2. Import torontostreetsjoined.mif from the Tutorial Data folder.
3. Inthe MAP Views panel, add a new MAP Layer called Street Names and set the Feature type to Text.

Add MAP Layer

Layer name: Street Names
Feature type: [ [T] Text - l
Advanced:

[F] Base attribute schema on: | [0 torontostreetsioined_line
Check this option to inhesit the attribute structure from the specified kayes.

In the Type Character panel, set the font to Arial and its size to 8 pt. This will be the style for the labels.
Select several streets from torontostreetsjoined_line to be labeled.
On the MAPublisher toolbar, click the Label Features button. &

No A

Layer drop-down list select Street Names.

Feature Text Label

Layer Labels

Source Layer Column Destination

1 [ torontostreetsjoined_line [ Street v] [T Street Names -l

The Source Layer list shows the line, area, point and/or text layers currently containing selected data. For each

Only one Source Layer is listed (torontostreetsjoined_line). In the Column drop-down list, select Street. In the Text

layer, the Column drop-down list is populated with the attribute structure of that layer. Label the data based on

a column that holds the appropriate attribute values.

8. Inthe Label Settings area, click the Line Labels button on the left to assign MAPublisher line label settings (it
should be enabled by default, if not, click it).

In the Label Settings area, users can specify label preferences such as label position, alignment to lines
of latitude, minimum font sizes, and horizontal scaling to best place labels within polygons and paths.
MAPublisher places line labels intelligently, depending on the curvature and length of the line string.

9. Set the Label Position option to Descender. Leave all of the other options as their default.

Label Settings

X Label Type: @ Follow line, create textonapath () Don't follow line, create point text

Distance from start: @ Auto @ Fixed: 0%
Line Labels

Reverse right-to4eft paths (flip upside-down text): Enabled
Line Smoothing: [] Enabled Offset Smoothed Line: 4 pt
Area Labels Label Positon: () Baselne —§ @ Descender _ ©) Center —§—

Labels can be modified if they exceed the length of the line with the current default font size.
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10. Check the Adjust label if larger than line check box to activate the label rules. The order for the rules can be
changed by clicking on the rule and then pressing the Up or Down arrow button.

11. Check the Reduce font size check box to reduce the size of the font to a specified minimum size in points. The
default minimum font size value is set to 5 pt.

12. Check the Reduce horizontal scaling to a minimum of check box and set the value to 50%. This allows text to be
scaled down horizontally by the fraction specified to adjust the kerning of the text.

13. Check the Set all labels to the same minimum font size check box.

=

Adjust label if larger than line
-
Point Labels

Reduce font size to @ minimum of:  Spt &

Reduce horizontal scaling te a minimum of:  50% |2

Set all labels to the same minimum font size

If any of the labels have been adjusted in size due to the activation of a line adjustment rule, all labels can be
resized to the same size. In this case, it is set to reduce to a minimum of 5 pt.

14. Make sure your dialog box matches the graphics above and click OK to label your map.

15. Close the document without saving.
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9.2 Generate labels for an area layer using the MAP Tagger Tool

Create a new Adobe lllustrator document.

Import fsatoronto.mif from the Tutorial Data folder.

In the Adobe lllustrator Layers panel, create a new layer called Zone Names.

In the MAP Views panel, click and drag Zone Names into the fsatoronto MAP View, and set the Feature type to Text.
In the Type Character panel, set the font to Arial and its size to 8 pt. This will be the style for the labels.
Double-click the MAP Tagger Tool ?} button in the Adobe lllustrator Tools panel to open the Label Settings
dialog box.

ok wnN =

Similar to the Label Features in the previous tutorial, the label settings must be chosen before MAPublisher is
able to determine the attributes that will be labelled. The Source Layer list shows the line, area, point and/or text
layers currently containing selected data.

7. Inthe Label Settings dialog box, choose FSAin the Column drop-down list. This attribute contains the name of
every postal code zone in the selected MAP Layer. The destination layer, Zone Names, is chosen by default. Click
OK to confirm these settings.

Label Settings

Layer Labels

Seurce Layer Column Destination

1 [A fsatoronto_area {[S] FSA - [ [T] Zone Mames vl

Notice that the mouse cursor is now the MAP Tagger Tool cursor. Using the MAP Tagger Tool, click on any area
feature to label it. You can click multiple times on an area to label it more than once.

Note: To create leader lines, hold the Shift key and click and drag. Release when the leader line is the appropriate
length. To reopen the Label Settings dialog box, double-click the MAP Tagger Tool button.

8. Close the document without saving.
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9.3 Create knockouts for labels
1. Open Contours.ai from the Tutorial Data folder.

Three MAP layers are visible: contours_labels, contours_line and Background. The contour labels are positioned
above the contour lines. Use the Create Knockouts feature to mask the contour line below the label.

2. Inthe MAPublisher toolbar, click the Create Knockouts button .
3. Click the Select Layers icon and click the check box for contours_line, then click OK.

Creste Knockouts

| Layested comourn_ e = o
| Testioper: | M comionr _ntaeks v | e
| Mask cpadty:  300% £

) rphace mostrg kot

£ cpusity sk ” o Bastiorgt)

R correes using radns 5.0

4 Knockout bowes:
Leftbuffe: 0,008
Rightbuffer: 0.0
Tenbuffe:  0.00pn
ottom bffer: 0,00 px

Lit 3 cay bt

Teut shaped knockout:

The Create Knockouts feature bases the masks on the input of contours_line and contour_labels. Accept the
default settings shown above to see how the knockouts will look.

4. In the Create Knockouts dialog box, click OK.

The knockouts are created. However, the labels are too close to the contour ends. Adjust the masks by adding a
buffer and changing the transparency. There is no need to undo the previous step.

5. In the MAPublisher toolbar, click the Create Knockouts button.
6. Set the Mask opacity to 80%. In the Knockout boxes section, set both the Left and Right buffer to 5.00 pixels.
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Creste Knockouts

Liyer(s}: contours ne = ==

1

Text lager: | (M) contour _inbels =] |
Mask cpadty: 80% |1
| B eptace g st

£ cpasey mack g o Pactirpt]

Rourd cormers using radker: 5.0

4 Knockout bowes:
Leftbuffe: 5008
Fightbuffer: - 5002
Topbuffer:  0.00px
ottom bffer: 0,00 px

Lit 3 cay bt

Teut shaped knockout:

The Mask opacity adjusts the transparency of the contour lines so that they will be slightly visible (100% opacity
means that it is completely invisible). The side buffer adds space to the left and right sides of the label so that it
creates the effect that the contour lines are further away from the label. The reason there is no need to Undo the
previous mask is because the Replace existing knockouts option is checked.

7. Click OK to close the Create Knockouts dialog box.

R

N
\ N
\\ i 85 ..___\\_/

The knockouts are created with a 5 pixel buffer and 80% opacity. To further adjust the mask, change the settings
in the Transparency panel.

8. Inthe Adobe lllustrator Layers panel, click the target to select all art of contours_line layer. Go to the Window

menu and click Transparency. Click the Mask (right-hand frame). In the Adobe lllustrator Layers panel, click the
target to select all the art of <Opacity Mask>. In the Transparency panel, adjust the Opacity to see how it affects

the contour lines.

Normal w Opacty:| &0 b %
i -;‘" [ clip
- []Invert Mask

["|1sclzte Blending  [H] Knockout Group
["| opacity & Mask Define Kneckout Shape

9. Close the document without saving.
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10 Making Selections

See User Guide, Chapter 11
10.1 Create an attribute filter

Create a new Adobe lllustrator document

Import festreets.mif from the Tutorial Data folder. It is a line file depicting the major roads of Falls Church, Virginia.
Select festreets_line and click the MAP Selections button on the MAPublisher toolbar. ¢

Click the Create New MAP Selection button at the bottom of the panel.

HwnN =

MAP SELECTIONS

5. Inthe Name box, type Route number. Leave the type as Attribute Filter.

New MAP Selection

MName: Route Mumber
Type: | fim Attribute Fiter -
Layer(s): <Use current layer >

Expression: 7]

) Empty expression. In position: 0

6. Click the Expression Builder button |¢] to open the Expression Builder dialog box.
7. In the Objects list, under the heading fcstreets_line, double-click Number so that it is entered into the expression
entry box above. Click the equals (=) button and type "A25" (including quotes).

Expre e Builder

el [eolle] [=lh=lisliz] =lials o] e ]
M - 42 [ cance
g o
Bl e,
o The expresmonis vk, Foston: 13

Objects Deaeriplion
L festreets_line sumber
5| sLayertiame
B = Ty sprg
5 sHame wire )
B Svrtextout Drefault Valee:
B s
R ssckeiris Befesh urigue sples
B rowecined #
B nength o
B ractscse b
5] teame. Al
5 humber =

Note: To view the unique values of a specific attribute column, click display unique values under the Description
box. Click a value to enter it into the expression entry box. It recognizes the attribute as a string and places
quotations around the value.

8. Click OKto close the Edit Expression dialog box.
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MNew MAP Selection

Name: Route Number oK
Type: | fiw Attribute Filter vl P
Layer(s): <Use current layer> @
Expression: Mumber= "425" 7]

& The expression is valid,

The expression is valid.
9. Click OKonce more to apply the selection to the map data.

Lines corresponding to the selection parameters are selected and the MAP Selection is saved in the panel.

" ap B 3

10. Deselect all artwork and leave the document open for the next tutorial.

10.2 Create a spatial filter

Continue working with the previous tutorial.

1. In the MAP Selections panel, click the Create New MAP Selection button.

2. Inthe New MAP Selection dialog box, type Intersect Route A25 into the Name box. In the Type drop-down list,
choose Spatial Filter.

This spatial filter will select any roads that intersect with Route A25. Use the attribute filter that was created in
the previous tutorial.

3. Inthe Filter Using drop-down list, choose Existing MAP Selection. In the frame below, the attribute filter Route
Number is already chosen (because it is the only one).
4. Ensure that the Spatial Relationship drop-down list is set to Intersect and contain.
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5. Uncheck the Do not select art on the same layer as the ‘Filter Using' art option.

Since this spatial filter is selecting art on the one and only MAP layer, this option must be unchecked.

New MAP Selection

Name; IntersectRRoute A25 oK

Type: | () SpatialFiter - —

Filter Using: [?F_msung MAP Selection = ]

Existing MAP Selection: lfw Route Mumber v]

Options:

Select From Layer(s): <Alllayers> =
SEP—

Filter Text By:

[ Do not select art on the same layer as the Filter Using' art.

6. Make sure the dialog box matches the one above and click OK.

nburset Ruste AT%
lnsec £n BAK Salasdtion ot Nessthar

Roads that intersect Route A25 are selected and the MAP Selection is saved in the panel.

7. Deselect all artwork and leave the document open for the next tutorial.
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10.3 Create an art selection filter

Continue working with the previous tutorial.
1. Select all artwork on the fcstreets_line layer.
2. In the MAP Selections panel, click the Create New MAP Selection button.

3. Inthe New MAP Selection dialog box, type All Routes into the Name box. In the Type drop-down list, choose Art

Selection and click OK.

New MAP Selection

Name: Al Routes
Type: | 7] Art Selection -

Store the currently selected art.

All selected roads are saved as a MAP Selection in the panel. Now use the MAP Selections panel controls to
select subsets and add or remove selections altogether.

4. Inthe MAP Selections panel, select the Intersect Route A25 spatial filter and click the Remove from Current
Selection button.

All the roads that were based on the spatial filter are removed from the current selection.

5. Select the Route Number attribute filter and click the Add to Current Selection button.

Route A25 is added to the current selection. Experiment with different combinations to vary selections.

6. Close the document without saving.
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11 Working with Images
See User Guide, Chapter 13
11.1 Register an image with a reference file

Create a new Adobe lllustrator document in landscape mode Letter sized.

Import southchinasea.shp from the Tutorial Data folder.

In the MAP View panel create a new layer of Image type and name it Borneo.

Make sure that the Layer Borneo is selected. In the Adobe Illustrator menu, click File > Place, navigate to the
Tutorial Data folder, select the sample raster image file borneo.tif, and click Place.

HwnN =

The raster image is placed at a default position and scale in the center of the screen.

5. With the image selected, click the Register Image button on the MAPublisher toolbar. [,
6. Click the Load File button and select borneo.tfw from the Tutorial Data folder.

All boxes in the dialog box are updated to reflect the data contained in the reference info file. Click OK to close

the warning.
Register Image
. ]
o] ¥ 108.3375605 deg
e
Y. 7.7816585 deg
Load File...
Image Size: 854 by 957 pixels.
1Pixel = X 0.0127730000 deg
¥ 0.0127650000 deg
Constrain Proportions.
Effective Map Size:
X: 10.908142 deg
Yo 12.216105 deg
Reference File Coordinate System:
Uniroun

7. Click OK to register the image.
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The image is registered; its size and position have been changed to reflect the information in the reference file.

A

Note: A new map view can be created by registering an image on a non-map layer. The new map view will have the
same coordinate system of the registered image, the image will be scaled to fit the document size and placed
on an MAP Layer of the Image type. For more information on this see MAPublisher User Guide, Chapter 12.

8. Leave the document open for the next tutorial.

11.2 Register an image without a reference file

Continue working with the previous tutorial.

1. Select and delete the existing Borneo image, but leave the Borneo layer in the document.

2. With the Borneo layer highlighted, in the Adobe lllustrator menu, click File > Place, navigate to the Tutorial Data
folder, select the sample raster image file, borneo.tif, and click Place.

The raster image is brought in at a default position and scale in the center of the screen.
3. With the image selected, click the Register Image button on the MAPublisher toolbar.

One of the four corners of the raster image is what MAPublisher will use as the raster anchor point (Upper Left
Placement, Lower Left Placement, Upper Right Placement or Lower Right Placement).

4. Click the Upper Left Placement (top left corner of the blue diagram) and type the following values into the
Upper Left Placement X and Y boxes: X=108.3375605, Y=7.7816585.
5. Make sure that Constrain Proportions option is checked and type pixel size X equal to 0.012773.
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Register Image

prt ot et

X: 108.3375605 deg

Cancel
Y: 77816585 deg
Load File...

Image Size: 854 by 957 pixels
1Pl = [ % 0.012773 deq

Y: 0.012772999601977 deg

Canstrain Propartions

Effective Map Size:
[ % 1w.008142 deg
Y 12.223750619092 dea

Reference File Coordinate System:

Unknown

6. Make sure the dialog box matches above and click OK.

The image is registered to the selected layer. This method is useful if no reference file is available. However, it
is necessary to know the coordinates for one of the corners of the image as well as the pixel scale in order to
register the image correctly.

7. Leave the document open for the next tutorial.

88 | MAPublisher 8.6 Tutorial
11 Working with Images



11.3 Export a placed image as a georeferenced raster file

Continue working with the previous tutorial.
Starting from MAPublisher 8.4, a referenced image must be placed on an Image layer in order to export it.

1. To set the color mode, in the Adobe lllustrator menu, click File > Document Color Mode.

Scripts 3
Document Setup... Alt+Ctrl+P

Document Color Mode b | ¥ CMYK Color
File Infe... Alt+Shift+ Ctrl+1 RGB Color
Print... Ctrl+P

Exit Ctrl+Q

Select RGB Color or CMYK Color depending on the color mode required for the exported raster image.

2. For this example, choose (MYK Color.

3. With the Borneo layer selected within the southchinasea MAP View, choose Export "Borneo" from the MAP View
panel option menu.

4. Inthe Export Image dialog box, choose GeoTlFF in the Store Geography As drop-down list to set the
georeferencing output format.

Export Image

Store Geography As: |GeoTIFF -

Cancel

w

Click Save As and navigate to a location to save the export image.
6. Type a file name (e.g. MyBorneo.tif) for the export image and click Save to complete the export process.

.

+ Tuorial Oata » w | ip || seanen »

Hame Dite taken Tags
MAPWshAuthes Tuter,..

= e

Qunck Start Guide & Dat «
Tunerial Guide & Dats.
Tutorial Data
MAPWebAuthor Tu
b EmageFiles. -
File narne: MyBomentt -
Save astype: | GeaTIFE Fle 0 ) -

= Hide Folders Save [ Conce

The image of Borneo is exported as a GeoTIFF file using the coordinate system of the South China Sea layer.

7. Close the document without saving.
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12 Grids, Graticules and Indexes
See User Guide, Chapter 13
12.1 Create an index grid

1. Create a new Adobe Illustrator document.
2. Import world.mif from the Tutorial Data folder.
3. Inthe MAP Views panel, add a new MAP Layer called Grid and specify the Feature type as Legend.

< [ wold B
(@) orid
[A] vorid_area o

= |/] [Mon-MAaP layers]
A Layer1 5

1 MAP View v i OB w 3

Adobe graphic styles can be used to style grid lines. Create these prior to using the grids and graticules dialog
box and the styles will be available from the menus for your To use a style for a grid, one should first be created
before it can be applied. A default grid style is used if no styles are defined.

4. Use the Rectangle Tool to draw a small rectangle with no fill color, choose a blue stroke color, and set a 0.5 pt
stroke width.
5. Select the rectangle and drag it to Graphic Styles panel and rename it Grid Style. Delete the drawn blue rectangle.

GRAPHIC STYLES

NENEEE R

GRAPHIC STYLES

R EEER R

i

6. In the Adobe lllustrator menu, click Window > Type > Character Styles to open the Character Styles panel.

7. In the Character Styles panel, click the Create New Style button. Double-click Character Style 1, choose Basic
Character Formats, and choose an Arial font at 8 pt size. Change the Style Name to My Grid Font (see the Adobe
lllustrator Users Guide to learn more about Character Styles) and click OK.

Charscer Style Options

Syetre. RS

Garwral

Shyle Setings [ ] -

Baic Character Formats
Fort Family Ari
Forn Style Peguiar
Aadvanced Character Formats
Character Color
CpenT v Features

7 Provew -

8. Inthe Adobe lllustrator Layers panel, select the Grid layer. In the Adobe Illustrator menu, click the Grids and
Graticules button on the MAPublisher toolbar.
9. Inthe Grids and Graticules dialog box, click the Index Grid button to show its options. Leave the Number of
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Columns/Rows as the default of 10 for each box.

10. Under Grid Style Options, click the graphic style/custom style toggle icon and select My Grid from the Style
drop-down list to set the grid line style. To keep the border of the grid the same as the lines, select My Grid from
the drop-down list next to Draw Border.

Grid Style Options:
Line style: Style: [ [] Grid style = ]
Oraw border: styies [ enaste 3

11. Under Coordinate Values along Grid/Graticule Border, select the My Grid Font character style from each of the X Axis
style and Y Axis style drop-down lists.

12. In the Labeling diagram, click the letter/number of "A <«—> B" and "1 <«—> 2" to enable the labels for all sides
of the grid.

Labeling:
rb L - 2 11 Coordinate Values along Grid/Graticule Border:
¥ Axis style: <uve My Grid Font =
A ¥ A
A et
S P—
-3
TFline does not hit bounds, label -
[ 1 - 2 Ay
Place labels offline by: 6pt =]
Cell References:
Place labels offcellby: 6 pt = Number of decirals: 0 (]
e e Lol
s style: ] Morml Character Sty + U Grmminsm s Dislog units:
[ Apoly locale formatting to numbers

Clicking the letter or number enables or disables the display of labels on the grid. Clicking the bidirectional
arrow reverses the order of the labels. For this example, leave the bidirectional arrows as the default.

13. Make sure your settings match the ones above and click OK to create the index grid.

An index grid is placed on the map. Each cell carries an alphanumeric identifier. To edit an existing grid, choose
Object > Edit Index Grid to change the configuration settings or type of grid.

14. Save the document as MyGrid.ai. It will be used in Tutorial 12.4 Creating an Index: Feature Based.

MAPublisher 8.6 Tutorial 91
12 Grids, Graticules and Indexes



12.2 Create a graticule

N

w

92

Create a new Adobe lllustrator document.

Import world.mif from the Tutorial Data folder.

In the MAP Views panel, add a new MAP Layer called Graticule and specify the Feature type as Legend.

Draw a rectangle with no fill and a blue stroke of 1 pt, then click and drag the rectangle into the Graphic Styles
panel and rename it Grid Style. Delete the drawn blue rectangle after adding it to the panel.

In the Adobe lllustrator Layers panel, highlight the Graticule layer and click the Grids and Graticules button.

In the Grids and Graticules dialog box, click the Graticules button to show its options. Under Latitude, type 20 in
the Interval box. Under Longitude, type 20 in the Interval box.

Latitude: Longitude:

Interval: 20 o Interval: 20 @

Pass through: 0 o Pass through: 0 o

Graticules can be plotted to intersect at specific lines of latitude and longitude. Pass through values of zero
will create a graticule that passes through the Prime Meridian and the Equator. This graticule will have lines at
intervals of 20 degrees.

The Vertices slider controls the number of nodes to construct the graticule. Higher numbers should be used if
graticules are curved or in anticipation of transforming them. For now, leave the default setting.

The Don't Label option is used in situations where the projection is creating a curved graticule that may have a
section in one of the corners that do not need to be labelled. For example, when there is no data in the graticule
or when there is only a small portion of the graticule showing and it does not need to be labelled. For this
tutorial these options are not needed.

Under Grid Style Options, click the graphic style/custom style toggle icon and select My Grid from the Style
drop-down list to set the grid line style. To keep the border of the grid the same as the lines, select My Grid from
the drop-down list next to Draw Border.

Grid Style Options:

Line style: styles [ ] Grid style -

Draw border: Style: [Dsnd Style ']

In the Labeling diagram, click the Lng and Lat options located on each grid line. When enabled, the Lng and Lat
options display as a bold typeface. If needed, hover over each toggle to see its description.

Labeling:
[ | ——- 2 Tl

e
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9. Click OK to process the graticule.

A graticule is placed over the map. To edit a graticule, select it and choose Object > Edit Graticules.
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10. Close the document without saving.

12.3 Create a measured (UTM) grid

1. Create a new Adobe lllustrator document.

2. Import torontostreets.mif from the Tutorial Data folder and perform a coordinate system transformation to
NAD83 / UTM zone 17N, located in Projected > UTM > NAD83 (see MAPublisher User Guide, Chapter 4 or Tutorial 2.9).

3. Inthe MAP Views panel, add a new MAP Layer called Grid and specify the Feature type as Legend.

4. Create a Grid Style graphic style with a 1 pt width stroke. Also, create a My Grid Font character style using Arial font
and an 8 pt size (Tutorial 12.1).

5. Select the Grid layer and click the Grid and Graticules button on the MAPublisher toolbar.

6. Inthe Grids and Graticules dialog box, click the Measured Grid button to show its options. Set the Cell Size to
1000 (meters) for both the width and height. Leave the Positioning options as default.

7. Under Display Options, set the style to Grid Style. To keep the border of the grid the same as the lines, select My
Grid from the drop-down list next to Draw Border.

Cell Sizes

ﬁ it &0 » [ir] Partal cels get labeied
o |mest e - Mimian size of celis: 0% &

Positianing:

Grabades .!DDD

: =I=1=]
B (sl v o =

Messed G| | Grid Style Options:

the g (] stve: [T crtstyie =

7] Draw border:  [{al] Stte: [ [ rd Stre -

At the bottom of the dialog box, check the Append units to labels check box to show the units in the map
document. The unit drop-down list to the right shows the units (Meter).
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8. Inthe Labeling diagram box, click the X and Y label option at the end of each grid line. When selected the X and
Y labels turns bold.

9. Under Coordinate Values along Grid/Graticule Border, choose My Grid Font for both X Axis style and Y Axis style
drop-down lists. Leave Place label off line by the default of 6 pt.

Labeling:
; B Coordinate Values along Grid/Graticule Border:
1= L —— = ng Grid/
X Axis style: I swie My Grid Font - l
A x
AL A2 X Axis |abel rotation: [Honzoma\ - ]
¥ ¥ ¥ Axis style: [ e My Grid Fant = ]
:  Axis label rotation: [Horizontal -]
X
If line does not hit bounds, label None -
i | - ) _

Place labels offline by: & pt —
Cell References:

Place labels off cellby: 6 pt z Nomborofdeamas {0 |
Center style: T.] [Normal Character Sty + Label values: Coordinates - ]
Axes style: I [Normal Character Sty v Append units to labels Dialog units:
["] Apply locale formatting to numbers Mater -

Notice that labels in the Labeling diagram are highlighted with a green box when the mouse hovers over the
different labeling options.

10. Click Preview to see the grid and the settings that were chosen.

BIR0GA M BI906m 63006 m B3106a m E33068 m

" \% -
4836041 m —= 4036041 m

Grids and Graticules.

45041 m | — aU35041 M

B\

11. Click OK to confirm the settings of the Measured Grid.
A grid is placed on the map based on the specifications made. Each cell line has UTM map coordinate labels.
To edit an existing measured grid, go to Object > Edit Measured Grid to change the configuration Settings. If the

grid is moved, the grid labels will automatically adjust to new coordinates.

12. Close the document without saving.
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124 Create a feature based index

1. Open MyGrid.ai (saved from Tutorial 12.1).
2. Inthe Map Views panel, add a new MAP Layer called Index Label and specify the Feature type as Text.

Add MAP Layer
Layer name: Index Label oK.
Feature type: [ [T Text - l —
Advanced:

[ Base attribute schema on: | [&] world_area -
Check this aption to inhert the ttribute structure from the spechied layen,

3. Apply country labels to several or all of the countries using Label Features or the MAP Tagger Tool
(see Chapter 9).

Select the grid in the map document and click the Make Index button on the MAPublisher toolbar.

Choose the Make index based on label and matching feature position option. In the Label Layer drop-down list,
choose Index Label. In the Feature layer drop-down list, choose world_area (the layer that was labeled). In the Label

text matches attributes drop-down list, choose Country (the attribute column used to label the map).

s [ sovess., |

i
i

Mk indeéx based on label positon

Label layes: | M) Bt Lo -

Eratrr layer: | B workt_aren =]
Label bt madchecs atboboute: | 5] Coumbey =]

Feature layer: | Il workd_area

Attt M =ooscry

MAPublisher wil determine what features to index by matching
b bt trbde. b

index: wil be created for every grid ol in wkich the feature
e b foured.
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9.

10.

26

Advanced options are available for fine-tuning index appearance.

Click the Advanced button.
In the Advanced Options dialog box, choose Feature label from the Sort by drop-down list. Under Output

Formats, choose the Single-line expanded option. To add an attribute to the index, select additional attribute
columns in the list.

Advanced Opticrs
Soet By: |Featunlabel -_Z aprrdy Index Separaton E
Labed [lat | Attt [ &[] 2 [C] s [0 7 i) = :
Dutput Farmal: The seteter vl be e one selected sbave. -
[ e — e it Aspiutes pared
@ Srgle-dne expanded -
Huitiee
Toronan Ontario AS73

Edmerton AT
Vecouerr AL
a rmpa; oo
Han 5t a2

] st rovped teat s & s entry

Select Additsanal Altrdntes:
From lever: [ workd_srea

D =Upacey - Select Attributes |rom Bownding Geametry:

M #Componentount elect attrbuies b ndude fram & lyer which vl aoesr i the ndex es.
i o veaio

5] #Hame

I =sresDirection
W #Vererount
Bl =Snyle

B =Saichitinight
B #henenetes

B =PatnCiosed
B shrtScale

Ay locale formaitiing to rumbers {#.g. thousand separators)

For this example, Capital was chosen. The grid cell locator and feature name in the index file are separated by a
single tab. The index is sorted alphabetically by feature label.

Click OK to accept the advanced options and in the Make Index dialog box, click Save As to save the index.
Browse to a location to save the index, name it Mylndex.txt, and click Save.

") Mylndex.bet - Notepad = [ C e

File Edit Format View Help

Country  Country  Grid Locations .
Algeria Algeria  C506,0506

Brazil Erazil E4;F3 R4 F5,GA

Canada  Canada  AZA3A4EZE3B4,C2,03,04

China China BS;EY,CEC0809

Russia Russia  ALAZAZALASAGATASALATDE] B6BT BS;EXE10,C7,CC10

United States United States ALAZBLEZEBRCI,C2C304:D1,0203

A text file is created based on the specifications entered in the Make Index dialog box.

The index may be inserted into the map document by creating an Adobe Illustrator box and using the Place
command (File > Place).

Leave the document open for the next tutorial.
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12.5 Create a text based index

Continue working with the previous tutorial.

2. Select the Make index based on label position option.

1. Select the grid in the map document and click the Make Index button on the MAPublisher toolbar.

e ke sl b cremin by s s e e

Note:

Indexing by label position generates an index containing only grid cells that contain a text label within it.

Text labels are indexed according to the text object's anchor.

3. Click the Advanced button. Choose Grid Cell from the Sort index by drop-down list. Under Specify Index
Separator, to the right of Attribute, click the tab button. In the Edit Attribute-Grid Separator dialog box, type ",
into the Custom box and click OK.

Edit Attribute-Grid Separator

1 Tab
1 None

@ Ccustom:

!

=

The grid cell locator and feature label in the index file is separated by a single comma. The index is sorted
alpha-numerically by grid cell label.

In the Make Index dialog box, click Save As to save the index. Browse to a location to save the index, name it
MyGridIndex.txt, and click Save.

MyGridindextet - Notepad
File Edit Format \View Help

5. Close the document without saving.
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13 Scale Bars and North Arrows

See User Guide, Chapter 14

13.1 Create a scale bar

N

Open usa48.ai from the Tutorial Data folder.

On the MAPublisher toolbar, click the Scale Bar button. i When prompted, create a Legend layer.
In the Scale Bar dialog box, use the up and down arrow buttons to view scale bar styles (for this tutorial, use the
default one). Choose Kilometer in the Units drop-down list. In the Interval box, type 250.

Depending on the scale bar chosen, select the Number of horizontal lines to use in the plotted scale bar. These
settings create a scale bar that equates centimeters on the page to kilometers on the map.

In the Number of labeled intervals box, type 4. Set the Number of intervals to subdivide to 1 and the Number of sub
intervals to 5.

These settings create a scale bar that represents a total distance of 1000 km. It has four main intervals each
representing 250 km with the first interval further divided into five smaller intervals.

In the Labeling Options section. Click the Tick label appearance hyperlink to open the Edit Text Rendition dialog
box. Click the character style / custom style toggle icon so that [Normal Character Style] is displayed. Click OK.
Click the Display scale value check box, choose Show above from the drop-down list, and choose Align center.

Click the Display units to right of last interval label check box.

Click the Display page to map units ratio check box, choose Centimeters from the Page units for captions
drop-down list, and choose Show below from the Placement drop-down list.

Seale far

| = Scale 1:20,000,000 Cec ]|

- o
Q 250 500 750 1000 Kilemeters
1 Centimeter = 200,000 Kilometers T enan
Miain Bar tnusea Prsang k. ed
; g e
Uitz K = o
|’ § Eit S Bm
f—. ™
¥ Manton et sz
Interval Options:
Taarber of beled mbervals Amterenils)

Humbar o8 hanaental nas:

Number of inbervals to subdivide: 1 imervalls)

Humper of s enervas: 530-nizrvals] 2
Aply locale farmatting 82 numbers (e.g. thousand separstors) in interval labels
Add mtervalleft of o

[ —

Tk el : ] Momach Srte]

Tick label spacng: 0000 2

] isplary scale vausi Il Shaw acave = | | BB Mg cerier -

| Deaplery units b rght of last interval label
| Dot poge 1o mepuris sabo:
Pageuns for cagtons: [Centmesers .
Precsen: 3 deomalis)
s =) (s z

Look at the preview to see how these settings affect the look of the scale bar.

9. Click OK to close the Scale Bar dialog box.
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The Scale Bar is placed at the center of the page according to the defined Settings. If necessary, resize the scale
bar using the bounding box. The scale automatically adjusts after it is resized.

Scale 1: 20000000

0 250 500 750 1000Kilometers
1 Centimeter = 200 Kilometers

10. Click the scale bar to select it. Click and drag the top anchor of the bounding box slightly downward to resize
the scale bar. (Note: dragging it too much will prevent it from resizing).

.
Scale 1:20000000

Scale 1: 20000000

250 500 750 1000 Kilometers Cont er a0 K ot Kilometers
Centimeter = 200 Kilometers entimeter= llometers

11. Leave the document open for the next tutorial.

Note: The scale bar can edited through the Adobe lllustrator menu Object > Edit Scale Bar. When the MAP view is
rescaled, the scale bar dynamically updates. The scale bar can be expanded to be edited as regular Adobe
lllustrator artwork (however, doing so breaks the link to the MAP View scale value).

13.2 Create a north arrow

Continue working with the previous tutorial.
1. Inthe MAP Views panel, add a new MAP Layer called North Arrow and specify the Feature type as Legend.
2. Make sure the North Arrow layer is active and use the Adobe lllustrator Type tool to type the letter N.
3. Select the letter N and click the North Arrow button on the MAPublisher toolbar. Iy

N N

The type is changed from regular text (above left) to a north arrow (above right) and is aligned in the north
direction. North arrows can be created from any art object in Adobe Illustrator including symbols and
characters. Note that the north arrow created is added to the Symbols panel*.

4. In the MAP Views panel, double click the usa MAP View.
5. Inthe MAP View editor, set an Angle of 45 degrees, click the Auto Scale button and the center page alignment.

* Sample north arrow designs are located in the \Helpful Styles & Symbols\Symbols folder (see page iii).
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Edit "usa"

Zoom: 47.55%

P ik

Name: | usa Page Alignment

Scale: 1: 20000000.000000 %] || | AutoScale v| LL%: 307.842230 B ot ggg

Angle: 45.00 [%] degrees (Rl 65.555754 st oo

6. Click OK to accept the angle edits.

The north arrow is oriented according to the MAP View it is placed in. Any changes made to the coordinate
system or angle of the MAP View will cause the north arrow to automatically orient itself towards North.

Scale 1:24503191

0 250 500 750 1000 1250 1500 1750 Kilometers
1 Centimeter = 245.032 Kilometers

7. Close the document without saving.

100 | MAPublisher 8.6 Tutorial
13 Scale Bars and North Arrows



14 MAP Web Author

See User Guide, Chapter 15
14.1 Prepare the map for web tags

1. In Adobe lllustrator, click File > Open, navigate to the \Tutorial Data\MAPWebAuthor_Tutorial folder and open the
Flash_Canada.ai tutorial document.

Canada i+l

Population 31,612,807
Area 9904670 k'

ko,
swﬁl
A  Ehatlotetown

A #ﬂ"hn

i

Before creating any Flash map, it is recommended to appropriately set the document size in Adobe lllustrator.
This will also determine the size of the Flash map. Use Document Setup or the Artboard Tool to set the
document dimensions. For this tutorial, the document is already set at 500 pixel width x 500 pixel height.

2. In the Adobe lllustrator menu, click the MAP Web Author button on the MAPublisher toolbar. 8
In the MAP Web Author panel option menu, choose Specify Source Media Folder.
4. Select the Relative Path option and leave the Source Media Folder field blank.

w

Specify Source Media Folder

() Absolute Path @ Relative Path Cancel

An amgzy relasive path indicates the same folder =5 the decumen,

This dialog box sets the path to the ImageFiles folder (the folder containing the image data) for Web tagging. To
indicate that the ImageFiles folder is in the same directory as Flash_Canada.ai, leave the path blank.

5. Click OK to close the Specify Source Media Folder dialog box.

6. Click a province on the map and open the MAP Attributes panel to become familiarized with the attribute
structure and data.

7. Close the MAP Attributes panel and continue to the next tutorial
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14.2 Create web tag callouts

This tutorial creates Web tag callouts for every object in the Provinces layer. These Web tags are used to expose
attribute information when map features are clicked.

1. Inthe Adobe Illustrator Layers panel, click the target button beside the Provinces layer name to select all art on
the layer.
@[ || [[] Major city names ]
| || [ Major cties o
Bl Provinces =
® [ || [=] backaround []
4 Layers ® 4ad @ #@ i

2. In the MAP Web Author panel, click the Edit button to open the Multiple Web Tag Dialog dialog box.

MAP WEB AUTHOR

Tag

Selection
All Web Art | | Web Art On Layer

[Selection contains non-web artwork]

[C]Zoom To Selected Art

3. Inthe Multiple Web Tag Dialog dialog box, type %NAME% into the Callout Title box.

4. In the Callout Image frame, make sure the By Attribute option is selected and type %IMAGE% into the box above.
Multiple Web Tag Dialog - Web Artwork 1 of 13 Selected ]
%NAME % HNunavut

x
Callout Image Width:  1s0px |2 f
Height: 160 s
iR Image Path: C:/Users/Public/Docum...ial/ImageFiles/NV.png e P
InsertImage: () Manually

Original: 80 x 45 pixels
@ By Atrbute

The %NAME% and %IMAGE% variables retrieve values from the Provinces attribute table. In the case of
%IMAGE%, the attribute is the image path. The image path and dimensions are shown on the right-hand side of

the frame. By default, the Callout Preview is enabled. This previews what the Web tag callout will look like when
exported to Flash.

Note: The attribute names are case sensitive and should match exactly as they are in the MAP Attribute table.
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Now, add more information to the Web tag callout by entering some basic HTML code. View the Callout Preview
to see how it changes as the code is typed.

5. In the main content entry box type the following:
<b>Province:</b> %NAME%<br>
<b>Population:</b> %Population%<br>
<b>Capital City:</b> %CapitalCity%<br><br>
Go to the <a href="%0fficialwebSite¥%'">government website</a>

6. Click the Auto Size check box.

Multiple Web Tag Dialog - Web Artwork 1 of 13 Selected 1
SENAME (Coloutpravien ] | Mnavet
* Provis N it
2IMAGE %a Height: | 150 pxc Capital City: Igaluit
: Image Path: [mixed] ) e
Insert Image: (0 Manually Auto Size Go to the government website

@ By Attribute

() (2] [=] [ee] [E]

<b>Province: </b> YNAMEY:<br >

<b>Population: </b> %:Population¥e<br >

<b>Capital City: </b> %CapitalCity %a<br»<br >

Go to the <a href="%0ffidalWeb%" »government website < /ax

Click here to see which HTML tags are supperied in Flssh.

Trigger External URL (Advanced)
Hover URL: Target: -

Click URL: Target: -
The specified URL(S) will be lnaded when the user bovers or clicks on this art, Use the taret tag to load the URL in a specific html frame.

Click the Previous and Next buttons to scroll through the Web tags for each province. The dialog box title bar
shows the current and total number of Web tags being edited. The Callouts can be manually resized, however,
the Auto Size feature ensures that content will fit properly inside each Web tag.

7. Click OK to save the web tags and to close the Multiple Web Tag Dialog dialog box.
8. The MAP Web Author panel displays that one web artwork is selected (out of 13).

MAP WEB AUTHOR

Tag

Selection
Web Artwork 1 of 13 selected.

["]Zoom To Selected Art

9. Keep the document open and continue with the next tutorial.
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14.3 Export Flash map

After creating the Web tags, the next step is to export the map to Flash so that it can be viewed in a Web browser
and shared over the Internet.
1.

In the MAP Web Author panel, click the Export button.

MAP WEB AUTHOR

Tag
r;

3 Export
)

Web Artwork 1 of 13 selected,

[F]Zeom To Selected Art

2.

In the Web Export Dialog dialog box, click the Browse button next to the Export Location box. In the Export File
dialog box, navigate to \Tutorial Data and create a new folder called canada. Save the file into the canada folder
and use the default file name of index.html. Click Save.

T Export File =]
@@vl < Tutorul Data” v/, canada = [*2] [search )
Folders v | Name E Date modified

| MAPublisher 8 -

| Helpful Styles & Symbols
. MAP LabelPro Tuterial Guide &
| Quick Start Guide & Data
| Tutorial Guide & Data
1 Tuterial Data
|\ canada

This folder is empty.

. MAPWebAuthor_Tutorial
| ImageFiles

| microsoft

==

v | — —

»
File name: index.html

Save as fype: [HTML (*.html *htm)

# Hide Folders

Web Export Dialog

Expart Settings ‘ ‘iewer Settings ‘

Expart

Export Location: =nza\MAPUblsher 8\Tutorial Guide &Data\Tutorial Data \canadaindex.html Cancel

The Export Location box populates with the new file path.
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3. Inthe Web Export Dialog Export Settings tab, locate the User Toggle column and check the check boxes for
Major city names, Major cities and Provinces.

Web Export Dialog
Export Settings | Viewer Style | Viewer Settings | Export...
Export Location: \Public\Documents\AvenzaMAPublisher 8{Tutarial Guide & DataTutorial Data\canadalindex. html
-

User Toggle Layer Name Options
Major city names .
Major cities
Provinces
[&] backgraund o

[Doubie Click Her To Set Layer Opt

The User Toggle allows the layers of a map to be turned on and off in the map interface.

4. Under the Options column for the Major city names layer, double-click to setup layer options. In the Layer
Export Options dialog box, choose Hide the layer when the map is initially loaded option and click OK.

Layer Export Options

Initial Visibility [E

(71 Show the layer when the map is initially loaded

z Cancel
@ Fide the layer when the map s initially loaded L
Export Settings | Viewer Style | Viewer Settings | Export...
Export Location: \Public\DocLments\Avenza MAPUblisher 8\Tutorial Guide & Data\Tutorial Data\canadayndex himl
User Toggle Layer Name Options -
Major city names Hidden when mapis initialy losded.
Major cities
Provinces
] background

The Options column now shows that the Major city names layer is hidden when the map is initially loaded.
Experiment with the other Layer Export options to see what kind of affect it has on the final map. Refer to the
MAPublisher 8.6 User Guide for more information.

5. Leave the other options in the Export Settings tab as the default and click the Viewer Style tab.
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6.

In the Viewer Style list, scroll down to Click Highlight Line and double-click the color value to change it. Select
a purple color (#aa00ff or RGB 170, 0, 255) and click OK. Double-click the Line Thickness value and change it

to 2. Scroll down to Hover Highlight Line and change the color to blue (#00aaff or RGB 0,170,255) and the Line
Thickness to 1.

Web Export Dialog ]
Export Settings Viewer Style Viewer Settings Export...
Name Value o Clase
4 Click Highlight Line

Visible true

Color W =a:00i

Transparency 07

Line Thickness 2
4 Hover Highlight Line

Visible true

Coler W =00aaff

Transparency 07

Line Thickness 1 |
4 Search Highlight Line

Visible true =

Calar SEFEN

The Viewer Styles are used to style Flash elements on the map. Do not confuse these with the MAP Stylesheets
or Adobe lllustrator graphic styles. These are strictly to style elements such as the Web tag callout, the
navigation buttons, overview map and search box. Changing the default Viewer Style settings creates a
Cascading Style Sheet (CSS) that contains CSS code that manipulates the look of the Flash elements. For more
information about this and MAP Web Author, see chapter 15 of the MAPublisher User Guide.

Leave the options in the Viewer Settings tab as the default and click Export.
After finishing export, the Web Export Log dialog box appears. It provides a summary of which layers were

exported, the corresponding export file name, the number of vertices in each layer and the Flash file sizes. It
also provides a link to the Export Folder that was specified earlier.

Web Export Log
Export folder; C:lsers Pubk sher STidoeinl G 8 Data/utaral porm—
‘et fokder permissiorss in the Plach Plaver Global Sequrity Zettings ool
1 Done
Layer File # of Vertices e
Mejor city nbmes map_LLswf a 10 KB
Magor cties map_LLswt a 1D
Provinces map_| 3sf [ 15 KB
background map Lswf a Tk

Fotal SWF file sice; 17400

Tha now sheck! e lams than LOOKIL for bt paviormance

Metadata {-xmd) e sioe: 1588

T iow sheockd b b than 55 KB comgruand o 200 KB srvrvgmmssec] e kst sarformarce,
Fo reduce exported fle soes:

Ut the "Smpify Lines” todl to reduce the number of vertices in your data,

= Export o frw atribustes s psbie, Only altiules thal sppear in Weh Togs aee ex prrted.
sUn-check the "Uise Preserve Appearance Setting for Flash Lport” settng.

wlise 3 bewer "IPEC Image Qualty & Resskiten” seHing,

sReduce the number of raster mages used i your map.

Note: Make sure you have properly configured permissions in the Flash Player Global Security Settings panel. See
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8. Click the Export Folder link to open the folder. The index.html is located in the export folder. Double-click the
index_data folder to view all of the map export files.

-
Name

T avenzajs

A expressinstall swf
Fimap.png

1 mapxml.zip

=] map_L1.swf

=) map_L2.swf

=) map_L3.swf

2] map_L4.swf

2 MAPublisherViewer.swf
=] MAPublisherViewer-local.swf
|| README bt
-';SMObJEEtJS

|| viewer_parameters.tt

Date modified

29/11/2011 6:25 PM
29/11/2011 6:24 PM
30/11/2011 2:51 PM
30/11/2011 2:51 PM
30/11/2011 2:51 PM
30/11/2011 2:51 PM
30/11/2011 2:51 PM
30/11/2011 2:51 PM
29/11/2011 6:25 PM
29/11/2011 6:25 PM
29/11/2011 6:24 PM
29/11/2011 6:24 PM
30/11/2011 2:51 PM

Type Size

J5cript Script File 5KB
Sheckwave Flash 1KB
Adobe Fireworks ... 80 KB
Compressed (zipp... 15KB
Sheckwave Flash 10KB
Shockwave Flash 1KB
Shockwave Flash 156 KB
Shockwave Flash TKB
Shockwave Flash 467 KB
Shockwave Flash 467 KB
Text Decument 3KB
IScript Script File 10KB
Text Document 1KB

9. Return to the canada folder and double-click index.html to open the Flash map in a Web browser.
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G0 19 the Qovernmant rebite

G i Canada B+l
Pa St 1
RO, e
ol i SN L e
TEFYI D D b
A -
TN il
¥ : = ‘J !
s
. - P’
"“*-q___'__,.‘__" F 'J/
— [ Mager eity namas
(] Mager ciian
| e e ] Brevincas

Navigate the map using the map zoom slider and zoom in and out buttons, the pan tools and using the mouse
to pan around the map. When the mouse hovers over a province, it highlights to the color specified earlier. Click
the province and the Web tag callout appears with information defined in the Multiple Web Tag Dialog. Notice
that the Major city names are hidden. This option was set earlier. Use the layers list to toggle the visibility of the
provinces, major cities and city names. The overview map in the bottom right corner can be used to navigate
the entire map without having to zoom out.

The latest Flash Player is required. It can be downloaded from the Adobe Website at www.adobe.com. If you
encounter a Flash permissions warning, please see the Avenza Systems forums at www.avenza.com/forum.

10. Close the document without saving.
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15 Geospatial PDF Export

15.1 Export to geospatial PDF

1. Open usa48.ai from the Tutorial Data folder.

2. Click the Export Geospatial PDF button on the MAPublisher toolbar. In the Export dialog box, choose
Geospatial PDF from the Save as type drop-down list. Navigate to the Tutorial Data directory, specify the file name
as tutorial15.pdf and click Save.

I Export =5
Savein: Titorial Data - @ o
B= Name = Date modified Type »
g | MAPWebAuthor_Tutorial
Recent Places NorthemOntario.gdb
Desktop
=
i
Ll
mlaw
B
LY
Computer
:l
=
Network
Fie name tutorial 15 pef -
Save astype: Geospatial PDF (*.PDF) v‘ [ Cancel ]
Use Artboards @ Al Range: |1

3. Inthe Geospatial PDF Export Settings dialog box, click usa_area to enable the Model Tree Preferences.
4. Click the check box beside Use attribute for item name. Make sure the sort order is set to Ascending and click the
Use Natural String Comparison check box.

Geospatial PDF Settings

Export attributes for layer:
Object Export Attributes
’ “
a4 @ MAP Views
4 @ usa
A usa_area

Model Tree Preferences [A] usa_area

Use attribute for item name: STATE_NAME -

Item Sorting:

Sart order: Ascending = ]

Use natural string comparison

Embed AI file within PDF

This setting will use the attributes of STATE_NAME, in an ascending sort order, in the Model Tree.
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5. Open the operating system file browser window and navigate to the Tutorial Data folder.
6. Double-click to open tutorial15.pdf in Adobe Acrobat Reader (the latest version is required).

1 uterisl]S poll - Adeke Aeeciat Pra =
Fie G0 View Windom Help x
oo | B eEw ecrpLDB "

oMo |=®==-]|HEA

The latest Acrobat Reader supports geospatial PDF files and comes with tools to explore the map. The Analyze
toolbar is located in the Tools menu. It holds three tools specific to geospatial PDFs: Object Data Tool, Measuring
Tool and Geospatial Location Tool. On the left hand side, there are two useful Navigation panels related to
geospatial PDFs: Layers and Model Tree. There are also Acrobat Reader preferences to change display elements

such as geographic units.

7. Click the Layers button in the Navigation panel to expand it. (If it is not present, right-click the Navigation panel

and choose Layers.)

Layers [
-

[@  usaarea

&‘%W‘\\\ = 0

Only the usa_area layer is present in this geospatial PDF. Click the eye button to toggle the layer's visibility.

MAPublisher 8.6 Tutorial | 109
15 Geospatial PDF Export



8. Click the Model Tree in the Navigation panel to expand it. Click the + symbol beside usa, then usa_area to
expand them. Click on a state to view its relative location on the map. Alternatively, use the Object Data Tool

and click features on the map.

L tutneaild pof - Adote Acabet Prs T
R
flowe: DESEZ @PPLLE W

ule | E@®(=~-1|H0 Tooks | Comment | Share

Mool Toee

Frogerty [
STATEHAME  Cabfuens

The Model Tree shows the map features of all the layers in the document. At the bottom of the Model Tree is a
window that displays attribute data. In this case, the state name for the feature selected is California.

9. ClickTools, click Analyze, then click the Geospatial Location Tool. A status window appears in the bottom-right
corner that displays the longitude and latitude of the cursor position.

+ (o [-]| & B Teals | Comment | Share
R
| » Pages

iiconlml
=

¥, v ', Astion Wisard
| » Recognire Text
"+ Protection
|+ sign ar crtity
E'Mllyzl

@ Object Dana Teol

: [y pae
=r { [ R ——

Latitude: 34B111 Longitude: -1059TM4 |

| 10x85in = ¥ ‘
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10. In the Analyze menu, click the Measuring Tool. Click the southeast corner of Oregon and draw a measurement
line to the southeast corner of Kansas. Use the Object Data Tool to find these states if you are unfamiliar with
the geography. (If necessary, zoom in to see the features in more detail).

+ (= [-||E 3 Tools | Comment | Share
- G-
* Pages
Seap Types Messemens Types
ik Con
o e I i B | L
4 | » Farme
¥ + Action Wisard

+ Recogniie Tt
» Protection
¥ sign & Conity

—
FITY - —
‘Geospatial Distance Tool
Distance: 121842 mi
Agimuth: 5731
Latitode: 35009 Longitude -S42574
NWOx8N0m ¢ m, 0

When the Measurement Tool is enabled, a secondary measurement toolbar appears that contains Snap Types
and Measurement Types. A status window in the bottom-right corner appears that displays information on the
distance measured, azimuth, latitude and longitude of the cursor position. In this case, the straight line distance
from Portland to Kansas is approximately 1218 miles (or about 1,960 km).

11. In the Acrobat Reader menu, click Edit > Preferences. In the Categories list, click Measuring (Geo).

Ferlrrerees =]
Cuegories Geospatial Measuring
Commentng | Messuring Line Color: [

Documents

Full Scrmen Measurerment Markup Settings

Grrirral ¥ Enable Messurement Markup
Page Griplay
Use Default Label
30 & Muktimedia e
Actessibilty Ll akeh
Action Wizard
Carpte Snap Settings
Calor Mansgerment i Soap o Cortant
Convert Frem POF
Convert To FOF E [Flpmms  [FPainEndpoints 7 Pach Micpoints (7] Path Intersections
Foms
Identity Snap Hint Color: (] Sengithety: i =
International
Internet - .
Latitude and Longitude Feamat
Iavacnipt g = =
Measuning (20) Display value as: | Decimal - Display direction az | Signed = |
Micasaring 05) e e PSR L T
 Abways display latitude and longitude as W5 1984
Multimedia {legacy)
Whukirivedia Trot Jagecy) ] Use default dtamcn unit: Miles -
Orikrse Sernces
Reading ¥ Use default area une: Square iles |
Reneaing e
Search 7] Don't shew trarsparency layer m GeoTIFF and BEG 2000 images
Securiy

Security (Erhanced)

This panel is used to change geospatial measuring options. See the MAPublisher User Guide for detailed
information on all of its options and settings.
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12. In the Display value as drop-down list, choose Degrees, Minutes, Seconds.
13. In the Use default distance unit drop-down list, choose Miles.

Latitude and Longitude Format

Display value as: | Degrees, Minutes, Seconds = Display direction as:

[¥] Always display latitude and longitude as WGS 1984

7] Use default distance unit:
[¥] Use default area unit: Square Miles -

Don't show transparency layer in GeoTIFF and JPEG 2000 images

14. Click OK to accept these settings.
15. Using the Measure Tool, choose several points to measure.

Snap Types Measurement Types

s O O

Geospatial Distance Tool
- Distance: 1243.79 km
Azimuth: 10670
Latitude: 447 49'16" Longitude: -101° 50' 2"

Notice that the distance is displayed in miles (km) and that the coordinates are displayed as Degrees, Minutes,
Seconds. Return to the Measuring (Geo) preferences to experiment with the settings to see how they can help
you explore geospatial PDF maps.
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16 Import Spatial Databases

16.1 Import Esri Personal or File geodatabase

Note: To work with this tutorial, an ArcGIS license is required. See the User Guide for more information.

In this tutorial, you will be importing data to be used for a Northern Ontario rail map.

1. In Adobe lllustrator, click File > New ,and create a new landscape oriented document.
2. Using Simple Import or Advanced Import click, from the Format drop-down list choose Esri File Geodatabase [*.gdb]

or Esri Personal Geodatabase [*.mdb].
3. Click Browse and in the Tutorial Data folder select NorthernOntario.gdb to open a File Geodatabase or

NorthernOntario.mdb to open a Personal Geodatabase.
4, The Select Feature Classes dialog box appears. Click the populated_points, canada_rail, and canada feature

classes to select them.

Select Feature Classes

@ select Feature Classes:
[[l canada_rail
Al canada

P populated_points

Specify Spatial Filter...
©) SQL Query:

Create SQL Select Query...

5. Click OK to close the Select Feature Classes dialog box and OK again to import the feature classes.

Notice on import that the imported point data covers all of North America. You will import the data again,
instead this time specifying a spatial filter and using SQL (Special Query Langauage) to perform an attribute
filter to limit the amount of imported data.

6. Click Edit > Undo to remove the imported data.
7. Use Simple or Advanced Import again to import the NorthernOntario geodatabase again.
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Note: To only use a spatial filter, click the Spatial Filter button on the Select Feature Classes dialog box.
To perform both a spatial filter and an SQL query simultaneously, choose SQL Query.

8. Inthe Select Feature Classes dialog box, choose SQL Query and click the Create SQL Select Query button.

5
Select Feature Classes

) Select Feature Classes:

ILl canada_rail Cancel

A canada
P! populated_points

Specify Spatial Filter...

@ 5QL Query:

Create SQL Select Query...

9. Inthe Create SQL Select Query dialog box, enter the following query:

SELECT * FROM populated_points WHERE populated_points.STATEABB='CA-ON’;
SELECT * FROM canada WHERE canada.NAME IN (‘Ontario}, 'Quebec, 'Manitoba');
SELECT * FROM canada_rail

Create SQL Select Query

EEOE

SELECT * FROM populated_points WHERE populated_points. STATEABE ='CA-ON';
SELECT * FROM canada WHERE canada.MAME IN (Ontario’, ‘Quebec’, ‘Manitoba’);
SELECT = FROM canada_rail

Validate
Select Feature Class or Attribute name:
> [L] canada_rail
- A canada

Pl populated_points
Add to Query

When creating & query, it is necessary to specify a single "SHAPE™ field in the select
dause,
To spedfy multiple SQL queries, separate them using a semicolon(;).

Specify Spatial Filter...

10. At the bottom of the dialog box, click the Specify Spatial Filter button.

Note: Note that the spatial filter has been defined by the extents of the data selected by the SQL query. Through
the spatial filter, you will further refine the selection to an envelope just beyond Northern Ontario.
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11. Ensure the Intersects relationship option is chosen and enter the following Lower left and Upper right
coordinate values:

Specify Spatial Filter

Relationship: @ Intersects () Contsins () Crop to Filter
Set Filter Extent:
Use extents of layer: =

@ Set points manually

Input Coordinate System: NADS3(1986) 3
Lower left:

« Long: -95.557020 deg

o lat  47.152100 deg
Upper rightz

« long: -78.775430 deg E
o lat:  57.473410 deg

The Intersects relationship option specifies that only data that intersects the spatial filter boundary will be
imported. Click OK to confirm these values, OK again to confirm the SQL Query, OK to close the Select Feature
Classes dialog box, and finally OK to import the features.

| N | —
- . 1 opotaten_jroines_pesen [&]
"y | Fp—— [E]
x [ —— 5
= L [Mon-as e
& o1 I

§ AR Vi e =B -

The feature classes are successfully imported using the SQL query and spatial filter.

12. Close the document without saving.
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16.2 Import Esri ArcSDE geodatabase

Esri ArcSDE technology is a means to interface with and access spatial data from an RDBMS (Relational Database
Management System). Data stored in an ArcSDE is accessed from a server, whether on an internal network, or
externally through the Internet. The Utah GIS Portal (http://gis.utah.gov) is one such resource that serves GIS data
free of charge. This tutorial requires the use of an Internet connection.

1. In Adobe lllustrator, click File > New ,and create a new landscape oriented document.

2. Using Simple or Advanced Import, choose Esri ArcSDE Geodatabase from the format drop-down list.

3. Click Browse. In the Browse ArcSDE Geodatabase dialog box, select Connections and click the Create New
button to enter the following parameters:

Connection Name: UtahGlISPortal
Server: gdb93.agrc.utah.gov
Service: 5151

Database Name: SGID93

User Name: agrc

Password: agrc

Transactional Version: sde.DEFAULT

Create New ArcSDE Geodatabase Connection

Connection Name: UtahGISPortal
S = dba3. .utah.

erver g agrc.utah.gov
Service: 5151

Database Name:  SGID93

@ Database Authentication
User Name: agrc
Password: eees
[ Check if you want MAPublisher to remember your password.

~) Operating System Authentication

Transactional Version: ' sde.DEFAULT Spedfy...
Test Connection

W

Optionally, click Test Connection to check whether these settings work. A message dialog box appears
informing you whether the connection was successful or not.

4. Click OK to confirm the connection settings.
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The UtahGISPortal connection is saved to the list. A saved connection can be accessed again in the future.

5. Inthe Browse ArcSDE Geodatabase dialog box, make sure UtahGISPortal is selected and click OK.

Browse ArcSDE Gecdatabase

Select Connection or MAP Dataset:

4 Connections
UtahGISPertal
Recent/saved MAP Datasets

[CrEaDENEw‘..][ Edit... H Copy...

I

Delete

l

-

Note: Depending on the Internet connection speed, it may take a few seconds to connect to the server.

6. In the Select Feature Classes dialog box, type Bioscience into the MAP Dataset box. Choose the feature at the top

of the list $G1D93.BIOSCIENCE.DominantVegetation and click OK.

Select Feature Classes

MAP Dataset: Bioscience

@ Select Feature Classes:

I 5GID33.BIOSCIENCE.DominantVegetation

[A 5GIDI3.BIOSCIENCE. Habitat_Bison

[A 5GIDI3.BIOSCIENCE. Habitat_Chukar

Al SGINS3.BIOSCIFNCE Hahitat Mnonse

[A SGID93.BIOSCIENCE. Habitat_BlackBear
[A SGIDI3.BIOSCIENCE.Habitat_BlueGrouse
[A SGID93 BIOSCIENCE.Habitat_BonetailedChub

[A SGID93 BIOSCIENCE.Habitat_CaliforniaBigHomSh...
[A 5GID93.BIOSCIENCE. Habitat_CaliforniaQuail

[A 5GID93.BIOSCIENCE. Habitat_BandtailedPigeon

[Al 5GID93.BIOSCIENCE. Habitat_DesertBighornSheep
[A 5GID93.BIOSCIENCE. Habitat_GambelsQuail
[A 5GID93.BIOSCIENCE. Habitat_HungarianPartridge

»

Specify Spatial Filter...
©) SQL Query:

Create SQL Select Query...

Note: After clicking OK, it may take a few minutes to retrieve the data from the ArcSDE server.
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7. Inthe Simple (or Advanced) Import dialog box, click OK again to finalize the import.

-

Simple Import
Format: ESRI ArcSDE | [ settings... |
- Cancel
Dataset:  Bioscience
Encoding: [Unicode, -bit (UTF-8) -]

Source Coordinate System:

MNADS3 { UTM zone 12M @

[ same as: | @ Energy

The DominantVegetation layer for Utah downloads and is imported into Adobe lllustrator successfully.

"3

= /

o

MAP VIEWS

v [@ Bioscience -
[A] sGID%3.E10SCIENCE. Dominantyagstatic... B

% A e = /] Non-Map layers]

/] tayert Py

2 Layers B & @

e A

Note: The connection parameters to this ArcSDE database service may have changed since the time of printing.
Updated parameters should be available on the Utah GIS Portal website located at http://gis.utah.gov.

8. Close the document without saving.
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16.3 Import basic Esri ArcSDE server

Users who do not have an ArcGlIS license can install the free Esri desktop application called ArcReader (see the Esri
Website for information - www.Esri.com). File and Personal Geodatabases cannot be read. Access to files with
Basic Esri ArcSDE Server connections is limited compared to the Esri ArcSDE Geodatabase connections.

1. In Adobe lllustrator, click File > New and create a new landscape oriented document.

2. Using Simple or Advanced Import, choose Basic Esri ArcSDE Basic from the Format drop-down list.

3. Click Browse. In the Browse Basic ArcSDE Server dialog box, select Connections and click the Create New button
to enter the following parameters:

Connection Name: UtahGISPortal_Basic
Server: gdb93.agrc.utah.gov

Service: 5151

Database Name: SGID93

Version: sde.DEFAULT

User Name: agrc

Password: agrc

Create New Basic ESRI ArcSDE Server Connection

Connection Name: UtahGISPortal_Basic
Server: adb93.grc.utah.gov
Service: 5151

Database Name:  5GIDS3

Version: sde.DEFAULT

User Name: agrc

Password: sae

[T] Check if you want MAPublisher to remember your password.

Test Connection

4. Click OK to confirm the connection settings.
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The UtahGISPortal_Basic connection is saved to the list. A saved connection can be accessed again in the future.

5. Inthe Browse ArcSDE Geodatabase dialog box, make sure UtahGISPortal_Basic is selected and click OK.

Browse ArcSDE Geodatabase
Select Connection or MAP Dataset:
4 Connections
UtahGiorta

Recent/saved MAP Datasets

CIEEDENEW‘.‘][ Edit... ][ Copy... H Delete ]

Note: Depending on the Internet connection speed, it may take a few seconds to connect to the server.

6. Inthe Select Feature Classes dialog box, type Bioscience into the MAP Dataset box. Choose the feature at the top
of the list SGID93.BIOSCIENCE.DominantVegetation and click OK.

Select Feature Classes

MAP Dataset: Bioscience oK

@ Select Feature Classes:

]E SGID93.BIOSCIENCE.DominantVegetation
[A] SGID93 BIOSCIENCE Habitat_BandtailedPigeon | |
[A 5GID93.BIOSCIENCE. Habitat_Bison

[A 5GIDI3.BIOSCIENCE. Habitat_BlackBear

[A 5GID93.BIOSCIENCE. Habitat_BlueGrouse

[A 5GID93.BIOSCIENCE. Habitat_BonetailedChub

[A 5GID93.BIOSCIENCE. Habitat_CaliforniaBigHornSh..,
[Al SGIDI3.BIOSCIENCE. Habitat_CaliforniaQuail

[A SGID93.BIOSCIENCE. Habitat_Chukar

[A SGID93 BIOSCIENCE.Habitat_DesertBighomSheep
[A 5GID93.BIOSCIENCE. Habitat_GambelsQuail

[A 5GIDI3.BIOSCIENCE.Habitat_HungarianPartridge
[A] SGINA3.BIOSCIFNCE Hahitat Mnonse

Specify Spatial Filter...

() SQL Query:

>

Create SQL Select Query...

Note: After clicking OK, it may awhile to retrieve the data from the ArcSDE server.
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7. Inthe Simple (or Advanced) Import dialog box, click OK again to finalize the import.

-

Simple Import
oK
Format: |Basic ESRI ArcSDE Server =] [ settngs... |
Cancel
Dataset:  Bioscience Browse...
Encoding: [Unimde, 8-bit (UTF-8) v]

Source Coordinate System:

MADS3 { UTM zone 12N @

Same as:

The DominantVegetation layer for Utah downloads and is imported into Adobe lllustrator successfully.

"3

= /

o

MAP VIEWS
v [@ Bioscience -
~
[A] sGID%3.E10SCIENCE. Dominantyagstatic... [

A % A e = /] Non-Map layers]
2 B = -

/] tayert Py

=,
1 4
% By ‘Q % L MAP Viewt v wL vl w3

2 Layers B & @

e A

Note: The connection parameters to this ArcSDE database service may have changed since the time of printing.
Updated parameters should be available on the Utah GIS Portal website located at http://gis.utah.gov.

8. Close the document without saving.
Congratulations! You have completed the MAPublisher Tutorial Guide. Please see the MAPublisher 8.6 User

Guide for more detail and information on specific features and commands. Check the Avenza Systems web site
and forums for updates and more information.
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